Tagged: suche Toggle Comment Threads | Keyboard Shortcuts

  • tkrogull 10:47 am on August 29, 2016 Permalink | Flag unresolved

      Tags: , , suche   

      [Bugis] Suche (Widget) funktioniert nicht 

      Hallo Elmastudio-Team,

      ich habe das Bugis-Theme auf meinem Blog (blog.meinekatzeundich.de) in Nutzung. Das Theme läuft auf WP 4.6

      Jetzt ist mir aufgefallen, dass die Suche leider nicht funktioniert.

      Ich habe das Phänomen, dass, wenn ich etwas suche immer nur ein ganz bestimmter Post “angezogen” wird, anstatt, dass alle passenden Ergebnisse angezeigt werden. Warum, wieso genau es immer nur dieser Post ist, kann ich nicht nachvollziehen. Ich habe mich schon durch sehr viele WP-Infoseiten gearbeitet, aber ich bin der Lösung keinen Schritt weitergekommen.

      Dadurch, dass anscheinend immer nur in diesem einen Post statt im gesamtem Blog gesucht wird, generiert die Suche leider immer wieder 404.

      Wenn ihr Euch das anschaut, nehmt Suchbegriffe wie “Simon” oder “Katzenpflanzen”. Das sind Begriffe, die neben dem Wort “Katze” definitiv im Blog vorkommen.

      Ergänzung:
      In der Zwischenzeit habe ich herausgefunden, warum immer diese eine Post angezogen wurde. Mit Firebug im FF konnte ich folgenden Code auslesen:
      form id=”searchform” action=”http://blog.meinekatzeundich.de/url” method=”get”.

      Da der betreffende Post mit “url” anfängt, wird dieser immer aufgerufen. Ich habe den Link zum Post inzwischen umbenannt. Jetzt wird er nicht mehr angezogen, aber der Fehler ist nach wie vor da.

      Woher kommt diese “/url”-Ergänzung?

      Gruß aus dem Rheinland,
      Tina

       
      • tkrogull 4:40 pm on August 29, 2016 Permalink | Log in to Reply

        Hallo Elmastudio-Team,

        ich habe den Fehler gefunden!

        In der Bugis functions.php steht in einer Zeile unter
        /*———————————————————————————–*/
        /* Customize the Bugis search form
        /*———————————————————————————–*/

        action=”‘.home_url(‘url’).'”

        Dieses “url” ist die Ursache gewesen, dass die Suche 404er generiert hat.

        Ob es ein Bug ist könnt ihr besser als ich beurteilen.

        Gruß,
        Tina

        • Marc (Support-Team) 10:19 am on August 30, 2016 Permalink | Log in to Reply

          Hallo Tina,

          vielen Dank für den Hinweis. Ich werde dies entsprechend weiterleiten, so dass es in einem zukünftigen Theme-Update berücksichtigt werden kann.

          Viele Grüße
          Marc

        • Marcus Voss 3:16 pm on October 4, 2016 Permalink | Log in to Reply

          Hallo Tina,

          ich habe das gleiche Problem mit der Suchroutine.
          Was hast Du denn genau im Code in der functions.php entfernt bzw. geändert?

          /*———————————————————————————–*/
          /* Customize the Bugis search form
          /*———————————————————————————–*/
          function bugis_search_form( $form ) {

          $form = ‘

          Wie muss denn der Code hinter “action…” aussehen?
          Hast Du nur das (‘url’) entfernt?

          Dank’ Dir.

          Gruss,
          Marcus

          • Marc (Support-Team) 8:50 am on October 10, 2016 Permalink | Log in to Reply

            Hallo Marcus,

            bitte ändere die folgende Zeile

                $form = '	<form method="get" id="searchform" action="'.home_url('url').'">

            in diese ab:

                $form = '	<form method="get" id="searchform" action="'.home_url('/').'">

            Viele Grüße
            Marc

    • Frank Fischer 8:59 am on May 3, 2016 Permalink | Resolved
      • Ellen (Support-Team) marked this resolved
        10:12 am on May 3, 2016
      • Ellen (Support-Team) marked this unresolved
        10:12 am on May 3, 2016

      Tags: suche,   

      Volltextsuche Weta ausbelnden 

      Hallo, liebe Elmaleute, ich finde keine Einstellung, wo ich die Volltextsuxche (mit Lupensymbol) verschwinden lassen kann. Bin ich jetzt zu blöd? oder geht das nur mit “visibility: hidden”?

       
      • Frank Fischer 9:10 am on May 3, 2016 Permalink | Log in to Reply

        Ich habe es jetzt ausgeblendet mit
        #search-btn {
        display: none;
        }

    • karowald 8:18 am on December 15, 2014 Permalink | Flag unresolved
      • TBecker_WW marked this normal
        7:06 pm on January 19, 2015
      • Ellen (Support-Team) marked this resolved
        4:07 pm on December 18, 2014
      • Ellen (Support-Team) marked this unresolved
        4:07 pm on December 18, 2014

      Tags: , , , , , suche   

      Hallo, ich benötige eure Hilfe! Ich möchte, wenn ich das Standardtemplate benutze, nur “letzte Beiträge” angezeigt bekommen, d.h. der Suchschlitz soll weg und auch Archive und Kategorien. Wie kann ich das umsetzen? Und besteht die Möglichkeit, die Überschrift “Letzte Beiträge” umzubenennen in z.B. “Aktuelles”? Und kann ich die Schriftfarbe des aktuellesten Beitrags ändern, sodass gleich auffällt, wenn hier etwas “Neues steht”. Herzlichen Dank im Voraus.

       
      • Ellen (Support-Team) 4:06 pm on December 18, 2014 Permalink | Log in to Reply

        Hallo,
        ich glaube, wenn ich dir richtig verstehe, kannst du alles in den Widget-Einstellungen einrichten (unter Design / Widgets). Dort kannst du die Standard-Widgets aus der Sidebar entfernen (per Drag’n’Drop) und auch die Widget titel ändern.

        Viele Grüße, Ellen

    • djsubotage 2:18 pm on October 14, 2014 Permalink | Flag unresolved

        Tags: , suche,   

        In dem Piha-Theme auf unserem Blog blog.x17.de funktioniert die Suchfunktion nicht wirklich. Es werden zwar Beiträge gefunden, wenn ich haber z.B. nach dem Begriff “schlüsselanhänger” suche, wird nix gefunden. Hier haben wir aber einen Beitrag zu und auch die entsp. Schlagworte!

        Woran kann das liegen?

         
        • Marc (Support-Team) 10:39 am on October 17, 2014 Permalink | Log in to Reply

          Hallo,

          Schlagwörter werden leider nicht durchsucht. Aber du hast deinen Beispiel-Begriff ja auch in Titel und Inhalten deiner Beiträge. Ich habe etwas herumprobiert und vermute ein Problem mit dem Encoding. Leider vermag ich nicht genau die problematische Stelle herauszufinden.

          Nach Eingabe eines Suchbegriffs mit Umlaut, wird dieses an irgendeiner Stelle falsch umgewandelt und so sieht dir URL, die aufgerufen und zur Anzeige der Suchergebnisse genutzt wird so aus: http://www.x17.de/de/blog/?s=schl%25C3%25BCssel&submit=Suche

          Um sicher zu gehen, dass es nicht am Theme liegt, könntest du einmal auf ein mitgeliefertes Twenty* Theme umschalten und erneut suchen. Ich gehe aber davon aus, dass es an WordPress selbst bzw. der Datenbank liegt. Prüfe bitte einmal die Kollation deiner Datenbank, hier wäre eine UTF8-Variante ratsam. WordPress legt die Tabellen eigentlich korrekt an bei der Installation, solltest du jedoch die Datenbank einmal umgezogen haben, könnte hier ein Problem entstanden sein.

          Wenn du sicherstellen konntest, dass das Problem nicht am Theme lag, versuche bitte Hilfe im WordPress-Forum zu finden, z.B. hier: http://forum.wpde.org
          Im anderen Fall, versuche bitte das Theme neu zu installieren, dann scheinen die Theme-Files falsch codiert worden zu sein.

          Viele Grüße
          Marc

      • elisa 12:57 pm on February 18, 2014 Permalink | Flag unresolved

          Tags: , suche   

          Suche funktioniert nicht bei moka 

          Hallo, ich bin begeistert von moka und habe jetzt meine HP damit aufgebaut.

          Allerdings funktioniert der “Suche”-Button bei mir nicht. Das Suchfeld geht auf und man kann auch was eintippen, aber es kommt kein Ergebnis sondern nur die Seite, die man zuvor aufgerufen hatte. Auf dem Computer (Mac mit Safari oder mit Google Chrome) und iPad geht es jedenfalls nicht – auf dem iPhone funktioniert es aber merkwürdigerweise?!?! Woran könnte das liegen, könnt ihr mir helfen? Vielen Dank

          http://www.biografienwerkstatt.de

           
          • Marc (Support-Team) 7:13 am on February 20, 2014 Permalink | Log in to Reply

            @elisa: Hallo, es hat den Anschein als läge es an der zusätzlichen Klasse, die dem Suchformular zugefügt wird: “wpl-track-me” Dieses wird vermutlich durch ein Plugin erledigt. Vielleicht erkennst du direkt um welches es sich handelt und kannst versuchen es zu deaktivieren, alternativ würde ich alle Plugins deaktivieren und nach und nach reaktivieren mit Funktionstests der Suche zwischendurch.

            Wenn du das schuldige Plugin gefunden kannst, können deren Entwickler vielleicht helfen.

            Viele Grüße
            Marc

        • nocheinefrage 7:54 am on December 10, 2013 Permalink | Flag unresolved

            Tags: , Lupensymbol, suche   

            Hallo,

            kann mir jemand sagen, wie man das Lupensymbol im Dorayaki-Theme entfernt? Mir würde es schon ausreichen, wenn es auf der Startseite nicht mehr sieht.

            Vielen Dank für Eure Hilfe.

             
            • Roland 10:36 am on December 10, 2013 Permalink | Log in to Reply

              Durchsuche die style.css, am besten mit notepad++, und lösche jeweils die Zeile “background-image: …… search.png”. Beziehungsweise auskommentieren, falls du es doch wieder mal haben willst.
              Eine andere Methode wäre im Ordner “images” das Lupensymbol durch ein eigenes Bild ersetzen. und das jetztige search.png umbenennen. Das eigene Bild kann ja weiß sein so dass man hinterher kein Symbol mehr sieht.

              • nocheinefrage 3:29 pm on December 10, 2013 Permalink | Log in to Reply

                Danke für deinen schnelle Hilfe. Die Idee mit dem auskommentieren gefällt mir sehr gut, nur leider bin ich ein totaler Noob wenn es um Webseitengedöns geht. Was muss ich denn da eintragen?

                Vielen Dank!

          • Kaori29 10:01 pm on August 7, 2013 Permalink | Flag unresolved

              Tags: , , , suche, , ,   

              Hallo zusammen,
              ich bin auf der Suche nach einem neuen Theme.
              Ich finde die Themes hier super schön und bin gerne bereit dafür zu bezahlen, aber ich weiß nicht genau welches Theme meinen Wünschen entspricht.
              Meine Website, auf die ich eine Elmastudio Theme packen möchte ist: http://www.lovelystamps.de

              Das neue Theme sollte auch 3 spalten haben, rechts und links jeweils schmale und in der Mitte die Blogbeiträge.
              Hätte aber gerne oben ein Bilder oder mehrere kleine Bilder nebeneinander oder einen Slider und darunter eine waagerechte Menüleiste… oder die Menüleiste über dem Bild – da bin ich nicht festgelegt.

              Da ich noch ein WordPress/Theme/ Blog – Neuling bin, bin ich mir nicht sicher welches Theme meinen Vorstellungen genau entspricht :(

              Es ist eigentlich auch möglich die Farben eines Themes zu ändern ohne ausschweifende Programmierungskenntnisse??

              Sorry für die vielen Fragen aber ich möchte einfach das richtige Theme für mich finden.

              Lg Vera

              PS: Geht bei einem Themewechsel mein bisheriger Bloginhalt verloren??

               
              • Marc Jandt 9:58 am on August 8, 2013 Permalink | Log in to Reply

                Hallo Vera,

                leider kann ich dir noch kein Theme für dein Projekt empfehlen, spiele zur Zeit noch mit allen herum :)

                Farben ändern geht relativ simpel, wenn es so weit ist, kann ich dir auch hier im Forum dabei helfen.

                Deine Beiträge gehen nicht verloren, also weder die Artikel noch die Seiten. Du musst ggf. die Widgets neu in den vorgesehenen Bereichen anordnen und die Seiten den richtigen Menüs zuweisen.

                Gerne helfe ich dir währende des Umbaus mit allen Stolpersteinen die eventuell auftauchen :)

                Viele Grüße
                Marc

              • Kaori29 11:10 pm on August 8, 2013 Permalink | Log in to Reply

                Danke für das nette Angebot. Muss mich am Sonntag nochmal in Ruhe hinsetzen und schauen welches Theme ich nehme. Oder vllt kommen hier noch ein paar Ratschläge zusammen

              • Kaori29 10:55 pm on August 11, 2013 Permalink | Log in to Reply

                Kann hier wirklich keiner sagen, mit welchem Theme ich das oben genannte machen kann??

                Das neue Theme sollte auch 3 spalten haben, rechts und links jeweils schmale und in der Mitte die Blogbeiträge.
                Hätte aber gerne oben ein Bilder oder mehrere kleine Bilder nebeneinander oder einen Slider und darunter eine waagerechte Menüleiste… oder die Menüleiste über dem Bild – da bin ich nicht festgelegt.

                Oder gibt es ein anderes Elmatheme wo ich oben genanntes mit umsetzen kann??

              • labos 10:19 pm on October 7, 2013 Permalink | Log in to Reply

                Hallo, hat sich Deine Anfrage inzwischen erledigt?

            • sonicate 2:37 pm on May 6, 2013 Permalink | Flag unresolved

                Tags: , , suche,   

                Renkon Suchergebnisse 

                Aloha again,

                beim Testen der Suchfunktion tritt auf der Ergebnisseite ein Fehler auf, z.B.: 7 Suchergebnisse für ‘Irgendwas’ -> angzeigt wird dann nur eine Überschrift als Ergebnis und diese wird dann (bei einem großen Bildschirm) angeschnitten. Offenbar reicht #content-wrap nicht weit genug.
                Leider konnte ich es nicht noch mal auf der Renkon-Demo Seite überprüfen, weil kein Suchfeld. Also weiss ich jetzt nicht ob ich im Code gepfuscht habe (ein paar css und php anpassungen -> wobei eigentlich nichts am content-wrap geändert) oder ob ein Fehler im Theme vorliegt. (?)
                Gerade eben noch aufgefallen: wird die Seitenleiste eingblendet, kann man links doch noch mehr Inhalte sehen. Menü zu, Ergebnisse weg. Also wie vorher beschrieben.

                lg

                 
                • Ellen 8:13 pm on May 6, 2013 Permalink | Log in to Reply

                  @sonicate: Vielen Dank für deinen Hinweis, ich habe die Suchfunktion gerade noch einmal in meiner Testinstallation ausprobiert, konnte aber den Fehler nicht entdecken. Könntest du mir vielleicht eine URL schicken mit der fehlerhaften Darstellung, dann kann ich mir den Code noch einmal anschauen und den Fehler besser nachvollziehen. Danke und viele Grüße, Ellen

                  • sonicate 11:14 am on May 7, 2013 Permalink | Log in to Reply

                    Hallo Ellen, du findest die Seite unter http://gabriele-kloepfer.de/inhalte/
                    Damit wir das gleiche sehen: ich habe nach “Assum” gesucht, 7 mal gefunden :) Getestet habe ich es in Firefox, Safari, Opera und Chrome. Ganz kurz werden alle Ergebnisse angezeigt und dann zieht es sich zusammen. Element untersuchen sagt dann “div#content-wrap 1436px x 163px”, beim Fenster verkleinern entsprechend weniger. LG, sonicate

              • webfacer 8:54 pm on February 6, 2013 Permalink | Flag unresolved

                  Tags: form, , suche,   

                  Tatami Suchfeld buggy 

                  Ich habe das Problem das die suche falsch dahrgestellt wird und zwar kleiner obwohl ich in der css nichts dergleichen verändert habe in der Klasse “.main-nav #s” habe das dann für mich auf 95% angepasst coderecho.com. Falls mal einer den selben fehler hat wie ich.

                  Eine andere sache ist auch die ich gern etwas anpasser, aber bin nicht so versiert in WordPress:

                  1) Ich möchte gern die PHP-File finden die die “Read more” enthält da möchte ich die Klammer wegtun die die “(…)” am ende des content umgibt

                  2) Und da ich das ändern möchte, habe ich schon oft versucht etwas im eigenen Editor per FTP-Client dies zu ändern jedoch habe ich keine schreibrechte kann man das irgendwie auch im WordPress aufheben. Ich könnte das eh per Filezilla lösen jedoch bin ich mit einem Fremden laptop unterwegs und kenne mein PW nicht auswendig. Wenn es da ne Hilfestellung gäbe wäre ich sehr dankbar.

                  Danke schon mal im vorhinein :D !

                   
                  • webfacer 8:15 pm on February 7, 2013 Permalink | Log in to Reply

                    oki ist erledigt aus irgendeinem grund passiert es das beim upload des zips der owner verändert wird. muss wohl etwas am server anpassen. File habe ich auch schon gefunden, war aber nicht einfach xD deswegen mag ich wordpress nicht aber es bietet viel.

                c
                compose new post
                j
                next post/next comment
                k
                previous post/previous comment
                r
                reply
                e
                edit
                o
                show/hide comments
                t
                go to top
                l
                go to login
                h
                show/hide help
                shift + esc
                cancel