Tagged: Nilmini Toggle Comment Threads | Keyboard Shortcuts

  • kOoLiNuS 5:53 pm on May 25, 2015 Permalink | Flag unresolved

      Tags: Nilmini   

      I was making some tweaks of my Nilmini installation and noticed there’s NO record for Instagram in that, while there are some that now are closed services (Zootool).
      Any chance to see this updated?

      Thanks

       
      • Marc (Support-Team) 12:11 pm on May 28, 2015 Permalink | Log in to Reply

        Hi,

        thank you for the info. I’ll forward this issue, so it can be addressed in an possible future update.

        You can edit the socialicons.png file within the images directory of Nilmini and replace any closed services icon. Within your widget you can simply use the corresponding input field for the URL to Instagram or any other missing service.

        Best,
        Marc

    • kOoLiNuS 11:36 am on May 14, 2015 Permalink | Flag unresolved

        Tags: black, , dark, Nilmini   

        a dark variant child theme for Nilmini 

        Hello there,

        anyone knows or has realized a black / dark version of Nilmini? TIA

         
        • Ellen (Support-Team) 10:35 am on May 19, 2015 Permalink | Log in to Reply

          Hi there,
          unfortunately I’m not aware of a black child theme version of Nilmini out theme, maybe anyone else knows?
          Best, Ellen

      • Mursonic 12:18 pm on April 21, 2015 Permalink | Flag unresolved

          Tags: , Nilmini   

          Hallo, mir ist erst jetzt aufgefallen, dass die Child-Elemente im Menü des Nilmini-Themes nicht funktionieren, wenn man sich die Seite auf einem Smartphone anguckt. Kann man gerne am Demo testen: http://themes.elmastudio.de/nilmini/

          Nun habe ich bei mir solche Child-Elemente aber mobile Nutzer können nicht drauf zugreifen. Wie kann ich das am besten heben? Ist ein essentielles Feature!

          Danke und viele Grüße!

           
          • Marc (Support-Team) 1:16 pm on April 23, 2015 Permalink | Log in to Reply

            Hallo,

            diese Option kannst du in den Theme-Optionen deaktivieren. In der Demo ist sie aktiv, wenn du die Child-Elemente jedoch anzeigen möchtest, entferne einfach den Haken im Dashboard unter Design -> Theme-Optionen (ganz unten).

            Viele Grüße
            Marc

        • S.ylvain 6:01 pm on January 5, 2015 Permalink | Unresolved
          • Ellen (Support-Team) marked this unresolved
            4:54 pm on January 7, 2015

          Tags: , , Nilmini   

          Nilmini: the excerpt function doesn't work 

          Hi,

           

          I start to use the Nilmini theme. I’ve a problem with it: the excerpt function doesn’t work. The full text is showed and there’s no “Read more” link.

          Do I have to modify something in the “functions.php” file?

          Thanks for the help.

          Regards,
          Sylvain

           
          • Ellen (Support-Team) 4:54 pm on January 7, 2015 Permalink | Log in to Reply

            Hi Sylvain,

            I’m sorry that I could not into the issue yet. Did you try to use the WordPress more link yet? If this is not working for you, I will look into the issue and let you know as soon as I have a solution.

            Thanks a lot for your patience!
            Best, Ellen

        • moellerhorcher 2:28 pm on October 23, 2014 Permalink | Flag unresolved

            Tags: , , Nilmini,   

            Nilmini Theme: Header Bild zentrieren 

            Hi,

            wie kann ich denn das Header Bilder mittig setzen?

            Link dazu: http://s398179016.online.de/mh/

            Vielen Dank.

            Grüße,
            möllerhorcher

             
          • EvermeetConsulting 12:06 pm on August 8, 2014 Permalink | Flag unresolved

              Tags: Nilmini   

              Hallo zusammen,

              das Nilmini-Theme soll responsiv sein. Leider zerreisst es die Menus auf iPads und iPhones. Ähnlich zerrissen sehen die Menus übrigens auf älteren IE Versionen aus (was ich jetzt nicht soooo schlimm aber immerhin unschön finde).

              Mache ich was falsch oder oder haben wir unterschiedliche Vorstellungen von “responsiv”?

              Link: http://www.bruckmeier-brandschutz.de

              Herzlichen Dank im Voraus für die Hilfe.

               
              • classic 1:49 pm on August 8, 2014 Permalink | Log in to Reply

                Hallo,

                das Theme ist schon Responsive, aber es ist auch ein etwas älteres Theme vom Elmastudio und damals war die Umsetzung eines Responsive Menü noch nicht so elegant wie es heute ist – meine Meinung :-)

                Rein vom Gefühl her könntest Du das Meola Theme mal ausprobieren, ich finde das kommt dem Nilmini am nächsten und dort ist das Menü deutlich eleganter.

                Zudem bietet das Meola die schöne Möglichkeit, das man mit einfachen Mitteln die Menüleiste am oberen Browserfenster festsetzen kann – auch nur so eine Idee.

                VG Peter

              • Marc (Support-Team) 8:51 am on August 11, 2014 Permalink | Log in to Reply

                Hallo,

                um bei einer größeren Menge Untermenüs, nicht alle in der mobilen Ansicht darzustellen, hat Nilmini eine extra Option um diese auszublenden. Du findest diese in den Theme-Optionen (ganz unten).

                So können sich die Besucher deiner Seite auch mit mobilen Geräten auf die Hauptpunkte konzentrieren und ggf. durch Verlinkungen auf den Seiten “tiefer” in die Menüstruktur eindringen.

                Wenn dir die Anordnung der Menüpunkte für mobile Geräte nicht gefällt, kannst du natürlich auch Änderungen mit CSS einpflegen um zum Beispiel zu erreichen, dass die Menüpunkte alle untereinander in voller Breite dargestellt werden.

                Viele Grüße
                Marc

              • EvermeetConsulting 3:18 pm on August 26, 2014 Permalink | Log in to Reply

                Danke, damit kann ich weiter arbeiten.
                (Kann es sein, dass die Benachrichtigungen im Forum nicht funktionieren?) ;)

            • kOoLiNuS 9:49 pm on June 29, 2014 Permalink | Flag unresolved

                Tags: , , Nilmini,   

                Hi there,
                on my http://koolinus.tevac.com website I’m having issues with fonts for post title… whatever font I choose from the WP Google Fonts plugins it gets ignored. I choose Exo 2 for all the fonts, except Exo for all the six header styles.

                I’m using the child theme, and of course the latest version of both. The funny thing is that on another blog of the network (http://foto.tevac.com) with almost the same config everything works. What am I doing wrong?
                Thanks in advance

                 
                • Marc (Support-Team) 1:00 pm on June 30, 2014 Permalink | Log in to Reply

                  Hi, this code is responsible for adding the CSS which overrides the settings made by your plugin:

                  <link rel="stylesheet" id="custom-css-css" type="text/css" href="http://koolinus.tevac.com/?custom-css=1&csblog=3&cscache=6&csrev=10">
                  

                  In most cases the JetPack plugin is embedding its custom css in this way. Normally you can find the settings in dashboard -> appearance -> edit CSS.

                  Best,
                  Marc

                  • kOoLiNuS 8:11 pm on June 30, 2014 Permalink | Log in to Reply

                    thank you Marc,
                    since I’m a CSS newbie I don’t know how to modifity this JetPack behaviour… can you help me a little bit further? Thanks!

                • kOoLiNuS 6:24 am on July 1, 2014 Permalink | Log in to Reply

                  Hi Marc, I’ve opened the Edit CSS and removed some style directive regarding Dosis font use. Now everything seems ok.
                  Thank you for the hint!

              • jrothhardt 8:33 am on June 12, 2014 Permalink | Flag unresolved

                  Tags: Nilmini, text in colums   

                  Hallo und guten Morgen,
                  meine neue Webseite betreibe ich mit dem Theme “Nilmini”. In der Dokumentation wird beschrieben wie man Text in 3 Spalten anlegt. Jetzt mein Problem? Wie ist es möglich diesen Text zu formatieren. Konkret ist es möglich eine Überschrift und Absatztext in der Visuellen Ansicht einzugeben oder muss ich da das Stylesheet anpassen? So sieht die Seite gerade aus: http://www.internet-projekt24.de
                  Danke für Ihre Hilfe.
                  Ihnen sonnige Grüße aus Calau und dem Spreewald
                  Ihr
                  Jörg Rothhardt
                  http://vital.gesundheit-tipps24.com

                   
                • barbara 5:22 pm on March 16, 2014 Permalink | Flag unresolved

                    Tags: , Nilmini   

                    Hei ich bin auf das SEO Tool von Yoast gestossen und da kann ich einen Breadcrump Code https://yoast.com/wordpress/plugins/breadcrumbs/ in das Theme einbinden. Nur wohin gehört die Datei? Welche Datei im Editor muss ich da verwenden? Kann mir da jemand von euch weiterhelfen.

                     
                    • Marc (Support-Team) 10:44 am on March 17, 2014 Permalink | Log in to Reply

                      @barbara: Hallo, wir können leider keinen Support für nicht unterstützte Plugins hier im Forum leisten. Wenn du den angegebenen Code in deine header.php vorm HEADER-End-Tag einträgst, sollte dich das einen Schritt weiter bringen.

                      Viele Grüße
                      Marc

                  • henrik 9:40 pm on March 3, 2014 Permalink | Flag unresolved

                      Tags: , Nilmini   

                      Hi, I have tried for HOURS to get the menu in Nilmini to be centered. Can you please give me a hint? I use Jetpack custom CSS for my efforts.

                      Skärmavbild 2014-03-03 kl. 21.37.40

                       
                    • johan 7:32 pm on February 13, 2014 Permalink | Flag unresolved

                        Tags: Nilmini   

                        Nilmini: Schriftart ändern für den content

                        Wie kann ich die Schriftart für den body-Inhalt ändern?
                        Ich finde nur die Option »Serifenschrift« / »serifenlose Schrift« in den Theme-Options.
                        Manuelle Eintragungen via #font-family im Stylesheet (unter general structure / body) führen zu keinen Ergebnissen.

                         
                        • Marc (Support-Team) 11:01 pm on February 13, 2014 Permalink | Log in to Reply

                          @johan: Hallo, schau doch mal unter dem Abschnitt “Post Content” in der style.css, dort findest du die Definition der Schriftart für den Inhaltsbereich.

                          Viele Grüße
                          Marc

                          • johan 9:15 am on February 17, 2014 Permalink | Log in to Reply

                            Danke für die Antwort. Leider führt das zu keinen Ergebnissen – überschreibt die Einstellung in den Theme Options manuelle Änderungen?

                      • johan 3:28 pm on February 6, 2014 Permalink | Flag unresolved

                          Tags: Nilmini   

                          Wie kann ich die Schriftart für den body-Inhalt ändern? Ich finde nur die Option »Serifenschrift« / »serifenlose Schrift« in den Theme-Options. Manuelle Eintragungen via #font-family im Stylesheet (unter general structure / body) führen zu keinen Ergebnissen.

                          — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — —

                          How can I change the font used for the main content? I only found the choice between »serif font« and »sans serif« on the Theme Options page. Editing the stylesheet via font-family (in general structure / body) doesn’t work.

                           
                        • johan 11:44 am on January 31, 2014 Permalink | Flag unresolved

                            Tags: Nilmini   

                            Apropos Nilmini: Wie kann ich die Schriftart für den body-Inhalt ändern? Ich finde nur die Option »Serifenschrift« / »serifenlose Schrift« in den Theme-Options. Manuelle Eintragungen via #font-family im Stylesheet (unter general structure / body) führen zu keinen Ergebnissen.

                            — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — —

                            Speaking of Nilmini: How can I change the font used for the main content? I only found the choice between »serif font« and »sans serif« on the Theme Options page. Editing the stylesheet via font-family (in general structure / body) doesn’t work.

                             
                          • johan 8:46 pm on January 30, 2014 Permalink | Flag unresolved

                              Tags: Nilmini   

                              Hallo.
                              Eine kurze Frage zum Nilmini-Theme: Wie schaffe ich es, die Hauptnavigation zentral auszurichten?
                              Ich dachte, das sei mit #main-nav und text-align:center getan (womöglich #main-nav ul). Dem ist aber nicht so.

                              — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — — —

                              Hello.
                              I have a question regarding the Nilmini theme: I want the main navigation to be centered, what do I have to do?
                              I assumed I just had to add text-align:center to the #main-nav (or maybe the #main-nav ul). But that doesn’t do the trick.

                               
                              • Marc (Support-Team) 7:13 am on February 1, 2014 Permalink | Log in to Reply

                                @johan: Hallo, leider können wir im Forum keinen Support bei CSS-Anpassungen leisten. Vielleicht hilft dir aber folgender Code weiter:

                                #main-nav .menu {
                                position: relative;
                                float: right;
                                left: -50%;
                                }
                                #main-nav .menu > ul {
                                position: relative;
                                left: 50%;
                                }
                                

                                Viele Grüße
                                Marc

                            • mAXx 11:59 pm on November 19, 2013 Permalink | Flag unresolved

                                Tags: , , Nilmini,   

                                Hallo Ihr Lieben,

                                auf 4 verschiedenen Blogs (Themse 1x Piha, 2x Bugs, 1x Nilmini) die auf 3 verschiedenen Servern laufen ist nach dem WordPressupdate die Lightbox verschwunden.
                                Ich verwende die Auto Thickbox. Auch ein Umstellen auf andere Lightboxen hat nichts gebracht.
                                Wenn ich das Theme z.B. auf “2012” oder auch eins der neueren Elmastudiothemes switche läuft die Lightbox wieder.
                                Habt ihr eine Idee wodran das liegen kann?

                                Danke für eure Hilfe.

                                LG
                                Thomas

                                 
                                • Ellen (Support-Team) 11:45 pm on November 22, 2013 Permalink | Log in to Reply

                                  @mAXx: Okay, das ist wirklich komisch, hatte die Lightbox-Funktion in den Themes denn vor dem Update funktioniert? Hattest du schon einmal getestet, das Plugin einmal kurz zu deaktivieren und dann neu zu aktivieren, manchmal hilft das nach einem Update. Ansonsten sag mir doch bitte eine URL, damit ich mir den Code noch einmal selbst anschauen kann. Welches Plugin nutzt du denn exakt? Grüße, Ellen

                                • Thomas Meurer 7:24 pm on January 1, 2014 Permalink | Log in to Reply

                                  Habe genau das gleiche Problem!

                                • Blumenberg 4:57 am on January 13, 2014 Permalink | Log in to Reply

                                  Habe auch das Problem auf http://thearchiveofthings.com/

                                  WordPress 3.8
                                  Theme: Renkon 1.0.2

                                  geteste Lightbox Plugins:

                                  Easy FancyBox 1.5.6
                                  FancyBox for WordPress 3.0.2
                                  Responsive Lightbox 1.3.2

                                  Verhalten:
                                  (1) Headerbild = AN → funktionieren die Lightbox-Plugins
                                  (2) Headerbild = AUS → funktionieren die Lightbox-Plugins _nicht_

                                  Anmerkung: Das Verhalten ist unabhängig davon, ob Jet-Pack aktiv oder inaktiv ist.

                                  Fix in Aussicht?

                                  • Thomas Meurer 11:43 am on January 13, 2014 Permalink | Log in to Reply

                                    Würde mich über eine Stellungnahme des Support-Teams freuen. Warte jetzt seit 13 Tagen auf eine Antwort!

                                    • Marc (Support-Team) 8:56 am on January 17, 2014 Permalink | Log in to Reply

                                      Hallo, bisher konnte ich das Problem nur mit Renkon bestätigen. Dort liegt zur Zeit nur der Workaround mit dem Entfernen der Zeile 104 in der functions.php vor.

                                      	if ( get_header_image())
                                      	wp_enqueue_script( 'fittext', get_template_directory_uri() . '/js/jquery.fittext.js', array( 'jquery' ), '1.1' );
                                      

                                      muss geändert werden in

                                      	wp_enqueue_script( 'fittext', get_template_directory_uri() . '/js/jquery.fittext.js', array( 'jquery' ), '1.1' );
                                      

                                      Viele Grüße
                                      Marc

                              • MarkusV 11:48 pm on November 17, 2013 Permalink | Flag unresolved

                                  Tags: Nilmini,   

                                  Hallo,
                                  bei mir sind leider die Share-Buttons am Ende jedes Artikels leider nicht sichtbar. Das Kurz-URL ist da.
                                  Ich hab nicht mit dem Quelltext rumgespielt, das Problem ist out-of-the-box.

                                  Könnt ihr mir bitte weiterhelfen?
                                  Danke!

                                   
                                  • Marc (Support-Team) 10:49 am on November 18, 2013 Permalink | Log in to Reply

                                    @markusv: Hallo, kannst du mir die betroffene Seite einmal zeigen? Verwendest du zusätzliche Minify- oder Caching-Plugins?

                                    Viele Grüße
                                    Marc

                                    • MarkusV 5:45 pm on November 18, 2013 Permalink | Log in to Reply

                                      Hallo Marc,
                                      meine Seite ist mutundfreude.at
                                      Ich hab keine Plugins oder sonstiges herumgeschraubt: Meine Fähigkeiten gehen nicht über das Anpassen von Farben hinaus :)

                                      Ich hatte gehofft, dass die Einrichtung des Blogs wirklich so einfach ist, wie in den Video Tutorials auf http://www.elmastudio.de/wordpress-themes/nilmini/ beschrieben.
                                      Na, mal sehen – ich bin optimistsch, dass eine Lösung auch in eurem Sinne ist :)
                                      Danke!
                                      Markus

                                      • Marc (Support-Team) 8:27 am on November 19, 2013 Permalink | Log in to Reply

                                        @markusv: Hast du bereits eine Lösung gefunden? Beim Aufruf deiner Seite kann ich die Share-Buttons alle sehen und diese sind auch funktionsfähig. Versuche doch mal einen anderen Browser um die Seite zu besuchen und deaktiviere alle Addons in deinem Browser, womöglich verursacht ein Werbeblocker oder Scriptblocker das Problem.

                                        Viele Grüße
                                        Marc

                                        • MarkusV 5:47 pm on November 19, 2013 Permalink | Log in to Reply

                                          Hallo Marc,
                                          der Werbeblocker war das Problem! Super Hinweis – danke!!
                                          Weiterhin viel Freude und Erfolg mit Elma,
                                          Markus

                                • Georg 1:10 pm on November 5, 2013 Permalink | Flag unresolved

                                    Tags: , , Nilmini,   

                                    Responsives Menu für Nilmini nur mit CSS? 

                                    Ich nutze in mehreren Projekten das wundebare Theme ‘Nilmini’. Das einzige, was mir in diesem Theme wirklich fehlt, ist ein responsives Menu wie es beispielsweise in den Themes ‘Baylys’ oder (noch besser) ‘Waipoua’ zum Einsatz kommt. Ich bin zwar in der Lage, über Manipulation der style.css eines Themes einiges zu erreichen, mit PHP und der grundlegenden Theme-Erstellung kenne ich mich aber nicht aus.

                                    Bevor ich mich nur verdaddel, um am Ende zu scheitern, vorher meine Frage: Ist es möglich – nur mit CSS – dem Theme  ‘Nilmini’ ein responsives Menu wie in  ‘Waipoua’ einzupflanzen? Oder würde man dafür viel stärker in den Aufbau des Themes eingreifen müssen?

                                    Falls irgendjemand  hier eine Antwort auf diese Frage weiss und bereit ist, mir da zu helfen… das wäre toll.

                                    Herzlich, Georg

                                     
                                    • Ellen (Support-Team) 3:42 pm on November 5, 2013 Permalink | Log in to Reply

                                      @Georg: Leider unterstützt das Nilmini Theme kein spezielles Responsive Menü mit Menü-Icon. Man könnte das sicherlich im CSS individuell einbinden, ein Update des Menüs ist leider momentan nicht geplant. Ich hoffe dir gefällt Nilmini dennoch weiterhin. Grüße, Ellen

                                      • Georg 5:39 pm on November 7, 2013 Permalink | Log in to Reply

                                        Hallo Ellen, danke für die fixe Info! Ich meinte das so: Lohnt es sich für mich, das mit CSS auszuprobieren (ich lerne gerne beim machen), oder geht es NUR mit CSS nicht? Wenn Du sagst, das geht schon mit CSS in der style.css, dann versuche ich es. Wenn Du sagst, da müsste man noch einige PHP-Dateen anpacken, lasse ich es bleiben.

                                        :)

                                        Herzliche Grüße von Georg

                                        • Georg 12:39 pm on November 11, 2013 Permalink | Log in to Reply

                                          Hi Ellen, ich hake nochmal nach. Es würde also nur mit CSS in der style.css gehen?

                                          Danke für kuzes ja oder nein :)

                                          Herzlich Georg

                                          • Marc (Support-Team) 11:35 am on November 13, 2013 Permalink | Log in to Reply

                                            @georg: Hi, es sollte alles mit CSS machbar sein. Das Ein- und Ausblenden bedarf dann allerdings einer kleinen JavaScript-Funktion.

                                            Viele Grüße
                                            Marc

                                  • barbara 10:24 pm on October 6, 2013 Permalink | Flag unresolved

                                      Tags: Nilmini   

                                      Social-Links und Favicon 

                                      Hallo Ellen,
                                      Dann gerne nochmal meine Frage hier im Forum. Ich habe zwei Themen, nachdem ich das Nilmini-Theme von dir eingesetzt habe, habe ich festgestellt, dass die Social Links überlappt dargestellt werden, habe schon versucht ob sich da ein kleiner Fehler im CSS eingeschlichen hat, doch nichts gefunden. Mein zweites Anliegen ist, dass Ich ein Favicon eingefügt habe, das nicht dargestellt wird. Hast du da Lösungen für mich? Hier meine Seite: http://www.barmedia.de

                                       
                                      • Marc (Support-Team) 1:56 pm on October 7, 2013 Permalink | Log in to Reply

                                        @barbara: Hallo, du hast am Ende deiner style.css folgendes CSS, welches diesen Effekt hervorruft:

                                        /*-----------------------------------------------------------------------------------*/
                                        /*	Externe Links
                                        /*-----------------------------------------------------------------------------------*/
                                        
                                        a[href^="http:"] { background: url(images/externallink.png) right center no-repeat; margin-right: 3px;padding-right: 13px;}
                                        a[href^="http://barmedia.de" { background: none; margin: 0; padding: 0;}
                                        

                                        Dein Favicon hast du vermutlich parallel zur WordPress-Installation abgelegt. WordPress verhindert in diesem Fall den Zugriff auf die Datei und leitet stattdessen auf die Fehlerseite um. Platziere die Datei am besten in deinem Theme-Ordner und gib den Pfad in den Theme-Optionen absolut an, z.B. so:

                                        http://www.barmedia.de/wp-content/themes/nilmini/images/favicon.ico
                                        

                                        Viele Grüße
                                        Marc

                                        • barbara 3:23 pm on October 7, 2013 Permalink | Log in to Reply

                                          Hi Marc,

                                          danke für deine Hilfe mit den SocialLinks hat wunderbar geklappt – danke. Nur mit dem Favicon, das habe ich noicht verstanden, wo soll ich was machen (Ich komme leider nicht aus der IT – also alles etwas neu). Ich erkläre mal was ich gemacht habe. Ich habe unter Theme Optionen das Feld eigenes favicon: /images/favicon.ico den Pfad eingetragen auf dem sich das favicon im FTP server befindet, das war alles…

                                          LG Gruß
                                          Barbara

                                          • Marc (Support-Team) 3:54 pm on October 7, 2013 Permalink | Log in to Reply

                                            @barbara: Hi, auf welchen Ordner hast du denn per FTP Zugriff?
                                            Welche Ordner befinden sich neben /images?

                                            Sollten sich daneben Ordner wie wp-content und ähnliche befinden, liegt dort direkt die WordPress-Installation. Das bedeutet du hast von außen keinen Zugriff auf die favicon.ico. Wenn dem so ist, kannst du durch die Ordner wp-content/themes/nilmini navigieren und dort das Favicon ablegen. Ich sehe nun gerade, dass sich in meinem vorigen Post durchs editieren etwas verändert hat. Die untere Code-Zeile sollte so aussehen:
                                            http://www.barmedia.de/wp-content/themes/nilmini/images/favicon.ico (für den Fall, dass du die Datei im images Ordner unterhalb von nilmini ablegst)

                                            Viele Grüße
                                            Marc

                                      • barbara 7:03 pm on October 7, 2013 Permalink | Log in to Reply

                                        @marcj Hei Marc, wunderbar, hat alles geklappt ich danke dir :)

                                    • Brigitte 5:18 pm on October 1, 2013 Permalink | Flag unresolved

                                        Tags: Nilmini   

                                        Hallo, ich habe gestern meine Seite auf das Nilmini-Theme umgestellt und nun ist mir das Suchfenster aus dem Header abhanden gekommen :-( Wenn ich es bei den Widgets wieder einfüge, dann erscheint es in der gleichen Spalte wie das Social Links Widget und über die ganze Breite des Themes. Es soll aber ja unter diese Social Links. Wie in der Live-Demo des Themes.

                                        Außerdem würde ich gerne auf manchen Seiten den Slogan nutzen und auf anderen das Headerbild. Kann man das einstellen? Ich habe die Frage hier schon gelesen – aber keine Antwort gefunden.

                                        Wäre toll, wenn mir jemand helfen kann :-)

                                        Brigitte

                                         
                                        • Marc (Support-Team) 9:45 am on October 2, 2013 Permalink | Log in to Reply

                                          @brigitte: Hallo, das Suchfeld ist kein eigenes Widget. Dieses kannst du in den Theme-Optionen deaktivieren. Vielleicht hast du aus Versehen dort einen Haken gesetzt. Bitte schau doch mal nach.

                                          Um auf bestimmten Seiten trotz Logo-Option stattdessen den Blogtitel anzeigen zu lassen, müsstest du die header.php Datei anpassen. Unterscheiden könntest du sie bestimmt mit der Verwendung von “Custom Fields”. Eine zusätzliche Abfrage, ob es sich um eine Seite mit dem entsprechenden Attribut handelt lässt sich relativ einfach in die header.php einbauen, denke ich :)

                                          Viele Grüße
                                          Marc

                                        • Marc Jandt 9:56 am on October 2, 2013 Permalink | Log in to Reply

                                          Da war ich doch glatt neugierig und habe dir das kurz gebaut :)
                                          Du könntest auf den Seiten, auf denen kein Logo angezeigt werden soll (ich weiß die Namensgebung ist gerade etwas schlecht gewählt, aber das kannst du ja auch anpassen) ein benutzerdefiniertes Feld mit dem Namen “showlogo” anlegen und diesem irgendeinen Wert zuweisen. Mehr zu benutzerdefinierten Feldern findest du hier: http://www.elmastudio.de/wordpress/jede-menge-moeglichkeiten-benutzerdefinierte-felder-in-wordpress/

                                          Danach würdest du folgende Anpassung an der header.php vornehmen. Ich empfehle dazu ein Child-Theme zu verwenden, die header.php dann ins Child-Theme-Verzeichnis zu kopieren und dort anzupasen. Dadurch verlierst du deine Änderungen im Fall von Updates nicht.

                                          Diese Zwei Zeilen ungefähr bei Zeile 80:

                                          					$options = get_option('nilmini_theme_options');
                                          					if( $options['custom_logo'] != '' ) : ?>
                                          

                                          in die folgenden ändern:

                                          					$custom_fields = get_post_custom();
                                          					$options = get_option('nilmini_theme_options');
                                          					if( $options['custom_logo'] != '' && !$custom_fields['showlogo'] ) : ?>
                                          

                                          Zur Erklärung: Es werden die benutzerdefinierten Felder abgefragt und in der Abfrage ob ein Logo angezeigt werden soll, wird zusätzlich geprüft ob nicht evtl. ein Feld mit Namen “showlogo” vorhanden ist und nur wenn es nicht vorhanden ist, wird das Logo gezeigt.

                                          Viele Grüße
                                          Marc

                                        • Brigitte 4:13 pm on October 2, 2013 Permalink | Log in to Reply

                                          Vielen Dank! Ja, da habe ich wohl aus irgendeinem Grund einen Haken gemacht. Jetzt ist das Suchfeld wieder da :-)

                                          Vielen Dank, Marc auch für die Zeilen. Doch hier haben wir uns missverstanden. Es geht mir nicht um das Logo, sondern das Headerimage und den Headerslogan. doch der Hinweis zu den Custom Fields ist großartig und ich werde mir das noch mal ansehen.
                                          Was ich gerne machen würde: Auf unterschiedlichen Seiten unterschiedliche Headerimages anzeigen oder auch mal statt Image den Headerslogan. – Aber vielleicht ist das zuviel erwartet ;-)

                                          Herzliche Grüße
                                          Brigitte

                                      • bethanyholmstrom 5:01 am on August 12, 2013 Permalink | Flag unresolved

                                          Tags: , Nilmini,   

                                          Hi there all,

                                          I was wondering if there was a way to change the code in Nilmini to get the Custom Header Slogan ONLY on my home/front page (the actual blog section). I *think* I have to change the code from the theme’s header.php (lines 117-121). Any ideas? I tried to doing a condition (if_home_page) sort of command instead of the “echo” part in line 120, but it turned into a hot mess and I had to give up.

                                          I’m new to code, so it might be an obvious/quick fix and I’m just not figuring it out!

                                          Thanks for any help,

                                          Bethany

                                           
                                        c
                                        compose new post
                                        j
                                        next post/next comment
                                        k
                                        previous post/previous comment
                                        r
                                        reply
                                        e
                                        edit
                                        o
                                        show/hide comments
                                        t
                                        go to top
                                        l
                                        go to login
                                        h
                                        show/hide help
                                        shift + esc
                                        cancel