Tagged: child theme Toggle Comment Threads | Keyboard Shortcuts

  • Mario472 3:37 pm on May 4, 2017 Permalink | | Flag unresolved

      Tags: child theme, ,   

      Dorayaki: Google Fonts via Child-Theme will nicht klappen 

      Hallo zusammen.
      Ich möchte im Dorayaki-Theme andere Google Fonts nutzen. Hierzu habe ich mir ein Child-Theme angelegt, was auch für andere Anpassungen ganz gut funktioniert. Zur Einbindung ‘meiner’ Google Fonts füge ich folgenden Code (aus Ellens Anleitungen) in die functions.php meines Child-Themes ein:
      /*-----------------------------------------------------------------------------------*/
      /* Load 2 Google Fonts
      /*-----------------------------------------------------------------------------------*/
      function dorayaki_fonts_url() {
      $fonts_url = '';

      /* Translators: If there are characters in your language that are not
      * supported by PT Sans or Raleway translate this to 'off'. Do not translate
      * into your own language.
      */
      $pt_sans = _x( 'on', 'PT Sans font: on or off', 'dorayaki' );

      $raleway = _x( 'on', 'Raleway font: on or off', 'dorayaki' );

      if ( 'off' !== $pt_sans || 'off' !== $raleway ) {
      $font_families = array();

      if ( 'off' !== $pt_sans )
      $font_families[] = 'PT Sans:400,700';

      if ( 'off' !== $raleway )
      $font_families[] = 'Raleway:400,900';

      $query_args = array(
      'family' => urlencode( implode( '|', $font_families ) ),
      'subset' => urlencode( 'latin,latin-ext' ),
      );
      $fonts_url = add_query_arg( $query_args, "//fonts.googleapis.com/css" );
      }

      return $fonts_url;
      }

      /*-----------------------------------------------------------------------------------*/
      /* Enque the Google Fonts
      /*-----------------------------------------------------------------------------------*/
      function dorayaki_scripts_styles() {
      wp_enqueue_style( 'dorayaki-fonts', dorayaki_fonts_url(), array(), null );
      }
      add_action( 'wp_enqueue_scripts', 'dorayaki_scripts_styles' );

      Sobald ich dann jedoch auf ‘Datei aktualisieren’ klicke, erhalte ich nur noch eine weiße Seite, egal ob ich den Abschnitt ‘Enque…’ einfüge oder nicht – und dann muss ich das Backup meiner functions.php wiederherstellen damit es wieder läuft (ohne die gewünschten Google Fonts).
      Was mache ich falsch? Ich sehe wahrscheinlich im Moment vor lauter Bäumen den Wald nicht mehr.

      Verweise auf Plugins bringen mich leider nicht weiter, sorry.

       
      • IDEART 4:02 pm on May 4, 2017 Permalink | Log in to Reply

        Hallo Mario472,

        warum machst du dir das Leben so schwer?
        Füge doch einfach im style.css deines Childthemes ganz oben nach:

        /*
        Theme Name:
        Theme URI:
        Description: Your child theme description text…
        Author: I
        Author URI:
        Template: dorayaki
        Version: 1.0
        Tags: Dorayaki Child Theme
        */

        /*
        Now you can start adding your own styles here. Use !important to overwrite styles if needed. */

        folgenden Code ein:

        @import url(‘https://fonts.googleapis.com/css?family=PT+Sans:400,700|Raleway:400,900’);

        und im weiteren Verlauf zur Spezifizierung der font-family:

        font-family: ‘Raleway’, sans-serif;
        font-family: ‘PT Sans’, sans-serif;

        Beachte aber: durch die zwei Schriften ist die Ladezeit moderat und nicht besonders schnell.

        Damit sollte es klappen! :-)

        IDEART

      • Mario472 4:07 pm on May 4, 2017 Permalink | Log in to Reply

        Das kann ja so einfach sein…

        Vielen Danke @IDEART! :-)

    • mOmOmO 3:19 pm on April 13, 2017 Permalink | | Flag unresolved
      • johanna2403 marked this normal
        4:20 pm on April 13, 2017
      • mOmOmO marked this resolved
        3:50 pm on April 13, 2017
      • mOmOmO marked this unresolved
        3:50 pm on April 13, 2017

      Tags: child theme, Custom CSS,   

      Dorayaki – Custom CSS funktioniert nur auf der Start-Seite korrekt 

      Hallo,

      ich benutze das Theme Dorayaki.

      Im Theme Customizer habe ich unter “Deine Anpassungen für Website-Informationen ” einen Titel für die Website eingegeben (“Cannstatter Kulturmenü”).

      Diesem Titel möchte ich eine andere Schriftart (Open Sans) über “Custom CSS” in den “Theme Optionen” zuweisen.

      mit meiner Custom CSS-Anweisung
      #site-title h1 a {color: #f4f4f4; font-family: ‘open_sansregular’;}
      erhalte ich NUR auf der Startseite das gewünschte Ergebnis: http://cannstatter-kulturmenue.de/

      Die Seiten “Kontakt” und “Impressum” zeigen den Titel zwar in der gewünschten Farbe, aber NICHT in der angegebenen Schriftart (weder im Header noch im Footer:

      Kontakt

      Impressum

      Das ist mir nicht erklärlich. Vielleicht weiß die Programmierin oder sonst wer Rat?

      Herzlichen Dank im Voraus!

      Beste Grüße
      MO

      Hier mein komplettes Custom CSS dazu:

      /* Header */
      #masthead {background: #880514;}
      #site-title h1 a {color: #f4f4f4; font-family: ‘open_sansregular’,’Lato’, ‘Helvetica Neue’; text-transform: uppercase; !important}

      /* Titel Veranstaltungsseiten */
      .page .entry-header h1.entry-title {
      font-family: ‘open_sansregular’,’Lato’, ‘Helvetica Neue’;
      font-size: 1.5em;
      text-transform: uppercase;
      }

      /* Titel Seiten */
      .entry-content p, .entry-content ul, .entry-content ol, .single-post .author-info p.author-description
      {font-family: ‘open_sansregular’,’Lato’, ‘Helvetica Neue’;}

      td {vertical-align: top;}
      table td {border-top: solid 2px #dcdcdc}

      /* Kontaktformular */
      div.wpcf7 {background: #f4f4f4; font-family: ‘open_sansregular’, ‘Lato’, ‘Helvetica Neue’;}

      /* Footer */
      .footerlabel-title {font-family: ‘open_sansregular’,’Lato’, ‘Helvetica Neue’; color: #f4f4f4; font-size: 12px;}
      .footerlabel-description {color: #f4f4f4;}
      .footerlabel {background: #880514; }
      #footerwidget-wrap .widget-area {border-top: 3px solid #f4f4f4;}

      /* Footer Navi */
      #colophon a {color: #f4f4f4;}
      #colophon a:hover {}

      /* FONTS *********************************************************************** */

      @font-face {
      font-family: ‘open_sansregular’;
      src: url(‘fonts/opensans-regular-webfont.woff2’) format(‘woff2’),
      url(‘opensans-regular-webfont.woff’) format(‘woff’);
      font-weight: normal;
      font-style: normal;

      }

       
      • johanna2403 4:18 pm on April 13, 2017 Permalink | Log in to Reply

        wahrscheinlich ist bei den anderen Seiten der Titel keine h1. versuch mal nur die Klasse site-title im css anzusprechen und dort die Informationen zu deiner Schrift reinzuschreiben.

      • Marc (Support-Team) 8:47 am on April 18, 2017 Permalink | Log in to Reply

        Hallo,

        bitte füge den von dir verwendeten Code erneut innerhalb des Code-Shortcodes hier im Forum ein. So lassen sich eventuelle Fehler, die von WordPress hier automatisch “eingebaut” werden ausschließen:
        [code]Dein Code hier…[/code]

        Viele Grüße
        Marc

    • justraveling 12:11 pm on April 10, 2017 Permalink | | Flag unresolved

        Tags: child theme, ,   

        Threaded Comments Weta Child 

        Hi there, I’ve noticed a very strange behavior on my Weta Child Theme. Threaded comments are enabled in the settings and should be supported by Weta. I didn’t change anything related to comments from the original css/php files, except for the font family and size, but threaded comments only show correctly if made directly from the dashboard by an administrator.

        If you, as a new user, try to reply to a comment on the site, your comment will inevitably show un-nested at the bottom of the list. Is that intentional (only administrators can reply to existing comments) or it’s a bug? How can I change that, allowing threaded comments for anybody? You can test it here: http://www.justraveling.com/travel-industry/united-colors-tourism/#comments.

        Many thanks for the support.

        Paolo

         
        • Marc (Support-Team) 12:59 pm on April 11, 2017 Permalink | Log in to Reply

          Hi Paolo,

          you are using the Jetpack comment feature. Unfortunately Weta isn’t especially prepared for it. Please ask the Jetpack support if it should be possible for guests to answer existing comments or if there are any special settings to make. Maybe you need to adjust the theme itself to support this functionality. The default WordPress comments are working as expected regarding this matter.

          Please understand that we cannot provide help for unsupported plugin features in the forum.

          Best,
          Marc

        • justraveling 8:01 pm on April 11, 2017 Permalink | Log in to Reply

          Thank you, I’ll do that.

          /best

          Paolo

      • DigitalExit 5:42 pm on February 6, 2017 Permalink | | Unresolved
        • DigitalExit marked this unresolved
          3:35 pm on February 21, 2017
        • DigitalExit marked this normal
          3:35 pm on February 21, 2017
        • DigitalExit marked this resolved
          3:35 pm on February 21, 2017
        • DigitalExit marked this unresolved
          5:42 pm on February 6, 2017

        Tags: child theme,   

        UKU: Serif style – Child Theme CSS order 

        Hi,

        ich möchte Uku Serif über ein Child Theme weiter anpassen.

        Mein Problem ist, der Uku Serif Style wird nach meinem Child Theme Style geladen, dadurch ist es mir nicht mehr möglich im Child Theme den Selektor passend zu überschreiben.

        Wie bekomme ich es hin, dass mein Child Theme als letzter Style auch Vorrang bekommt? Also Uku Style -> Uku Serif Style -> Uku Child Theme Style?

        Der Basiscode für das Childtheme ist 1:1 der Uku Child Theme Code von
        http://www.elmastudio.de/wordpress-themes/doks/uku/#uku-childtheme

        Aktuell sieht es im Code vom Header wie folgt aus:

        <link rel="stylesheet" id="parent-style-css" href="https://meine-domain.de/wp-content/themes/uku/style.css?ver=4.7.2" type="text/css" media="all">
        <link rel="stylesheet" id="uku-fonts-css" href="https://fonts.googleapis.com/css?family=Poppins%3A400%2C500%2C600%2C700%7CCormorant+Garamond%3A400%2C500%2C700%2C400i%2C700i&amp;subset=latin%2Clatin-ext" type="text/css" media="all">
        <link rel="stylesheet" id="uku-style-css" href="https://meine-domain.de/wp-content/themes/mein-child-theme-2.0/style.css?ver=20160507" type="text/css" media="all">
        <link rel="stylesheet" id="uku-serif-style-css" href="https://meine-domain.de/wp-content/themes/uku/assets/css/serif-style.css?ver=1.0" type="text/css" media="all">
        
         
        • Taruk 7:57 pm on February 6, 2017 Permalink | Log in to Reply

          Hi,
          probier mal folgendes in Deiner Child-Theme style.css:

          Wenn Du Definitionen aus der serif-style.css überschreiben möchtest, setze vor Deine Definition ein “.uku-serif”.

          Beispiel:

          p.entry-content {...} 
          

          wird zu

          .uku-serif p.entry-content {...}
          

          Dadurch sparst Du Dir ein !important bei jede serif Re-Definition, was ja verschiedene Nachteile hat.

          Gruß
          Taruk

          • Marc (Support-Team) 10:33 am on February 9, 2017 Permalink | Log in to Reply

            Hallo,

            du kannst die Selektoren wie von Taruk empfohlen expliziter gestalten. Diese haben Vorrang. Hier noch ein weiteres Beispiel um eine .uku-serif-Definition expliziter zu gestalten:

            .uku-serif .entry-content {...}
            
            body.uku-serif .entry-content {...}
            

            Viele Grüße
            Marc

        • DigitalExit 10:34 pm on February 13, 2017 Permalink | Log in to Reply

          Danke für die Info. Die Lösung ist natürlich nicht elegant, wenn man vor jeden einzelnen Selektor noch ein body.uku-serif packen muss.

          Warum ist Uku denn nicht in der Lage die eigenen Styles einzubinden bevor das Child-Theme sein Style einbindet? Lässt sich das nicht über die wp_enqueue_scripts Priorität sauber einordnen?

          Es müssten ja nur die zwei Zeilen ihre Reihenfolge wechseln, also wie folgt:

          <link rel="stylesheet" id="parent-style-css" href="https://meine-domain.de/wp-content/themes/uku/style.css?ver=4.7.2" type="text/css" media="all">
          <link rel="stylesheet" id="uku-serif-style-css" href="https://meine-domain.de/wp-content/themes/uku/assets/css/serif-style.css?ver=1.0" type="text/css" media="all">
          <link rel="stylesheet" id="uku-style-css" href="https://meine-domain.de/wp-content/themes/mein-child-theme-2.0/style.css?ver=20160507" type="text/css" media="all">
          

          Dann hätten wir das Problem gar nicht und man könnte einfach CSS-Blöcke aus dem Parent-Theme kopieren und neu definieren, ohne an der Spezifität noch etwas drehen zu müssen.

        • DigitalExit 3:37 pm on February 21, 2017 Permalink | Log in to Reply

          Mir fehlt immer noch Feedback zu meiner Frage!

      • kOoLiNuS 3:08 pm on February 3, 2017 Permalink | | Unresolved
        • kOoLiNuS marked this unresolved
          11:06 am on February 4, 2017

        Tags: child theme,   

        Suidobashi and the official child theme 

        Hello everybody!

        I do have a question – if I can – on this Suidobashi theme customisation. Using your child theme, if I add a footer.php and an header.php file in the child-theme directory copied from the parent and modified by adding the Google Analytics and the Cookie Script code everything get messed up.

        To be clear everything gets messed up even if the header and footer php file are simply copied and not modified.

        Usually I make my child themes using the https://wordpress.org/plugins/orbisius-child-theme-creator/ plugin and this has never happened to me. This time I wanted to use the author’s default child-theme files and this is the result…

        What’s the best behaviour to use them and make such modifications ?
        Thanks in advance

         
        • kOoLiNuS 7:26 pm on February 6, 2017 Permalink | Log in to Reply

          Well … It seems that my editor or a copy and past transformed a — into a — and a comment wasn’t closed.
          Before marking it closed, now, I have to debug why Cookie Script in the footer.php does not work …

          • Marc (Support-Team) 11:07 am on February 8, 2017 Permalink | Log in to Reply

            Hi,

            you can post the code you are using by using the following shortcode:

            [code]Your code here…[/code]

            I’ll check, what may be wrong with your code.

            An alternative for adding Google Analytics JavaScript is the use of plugins. There are analytics and opt out cookie plugins available in the plugin library.

            Best,
            Marc

      • Captain.Nemo 5:00 pm on January 2, 2017 Permalink | | Unresolved
        • Captain.Nemo marked this unresolved
          8:07 pm on January 4, 2017

        Tags: child theme, ,   

        Problem mit Ändern der Hintergrundfarbe bei Service-Box und Child Theme 

        Hallo Zusammen

        Ich wollte die Hintergrundfarbe der Service-Box beim Dorayaki anpassen. Mache ich dies direkt im original style.css (oder in den Theme Options (Include Custom CSS) funktioniert dies einwandfrei. Nutze ich denselben Code im CSS vom Child Theme funktioniert dies nicht mehr. Hat Jemand hierzu ev. eine Idee?

        So sieht der Code aus:
        a.service-box:hover,
        a#desktop-search-btn:hover,
        a#desktop-search-btn.btn-open {
        background: #9191c1;}

        Danke für einen Hinweis und Grüsse

         
        • Marc (Support-Team) 10:20 am on January 4, 2017 Permalink | Log in to Reply

          Hallo @captain-nemo,

          dies hängt mit der Reihenfolge zusammen, in der die style.css-Dateien geladen werden. Ein !important hinter der zu ändernden Eigenschaft sollte Abhilfe schaffen:

          a.service-box:hover,
          a#desktop-search-btn:hover,
          a#desktop-search-btn.btn-open {
          background: #9191c1 !important;
          }
          

          Nutze bitte den Code-Shortcode um Code im Forum einzufügen: [code]Dein Code hier…[/code]

          Viele Grüße
          Marc

          • Captain.Nemo 8:08 pm on January 4, 2017 Permalink | Log in to Reply

            Super, dies hat geholfen – Danke.

            Nun habe ich noch ein Problem dass zwischen den Boxen eine Art Aufyaehlungszeichen dargestellt wird. Ich nutze drei Boxen, und zwischen denen wird oben der Punkt angezeigt… Hattet ihr das schon mal?

      • Christopher 1:06 pm on December 29, 2016 Permalink | | Flag unresolved

          Tags: child theme, subfolder, Unterordner,   

          Zuki: Datei einen Unterordners anpassen mit einem Child Theme 

          Ich stehe aktuell vor dem Problem das ich die Datei /inc/widgets.php ändern möchte. Dies soll aber nicht in den Parent Theme Dateien geschehen sondern im Child.

          Nur leider wird der Unterordner mit der eingefügten Datei im Child Theme nicht beachtet. Gibt es da eine Möglichkeit, z.B. durch die functions.php, dies nachzuladen?

          Danke schonmal, Christopher ;)

           
          • Marc (Support-Team) 12:38 pm on December 31, 2016 Permalink | Log in to Reply

            Hallo Christopher,

            diese Datei ist keine typische Template-Datei, welche sich durch den dir bekannten Mechanismus ersetzen lässt. Der dort enthaltene Code wird durch die functions.php des Themes nachgeladen.

            Leider ist es recht aufwendig Änderungen am Widget-Code vorzunehmen.

            Ich empfehle dir auf Basis der widgets.php den Code der zu ändernden Widgets zu kopieren, anzupassen und ggf. in eine eigene widgets.php im Child-Theme abzulegen um mit der Child-Theme-functions.php dann geladen zu werden. In jedem Fall erhalten deine neuen Widgets jedoch andere Klassen-Namen, weshalb du zusätzlich eine Menge CSS-Code kopieren musst.

            Viele Grüße
            Marc

        • hiddenline 2:56 pm on April 21, 2016 Permalink | | Resolved
          • Ellen (Support-Team) marked this resolved
            3:14 pm on April 21, 2016
          • Ellen (Support-Team) marked this unresolved
            3:14 pm on April 21, 2016

          Tags: , child theme   

          Child themes 

          Hallo liebe Elmas,
          vor dem Relaunch Eurer Website war bei den einzelnen Beschreibungsseiten der Themes immer auch ein Link zu einem vorbereiteten Child-Theme.
          Jetzt kann ich das z.B. für Bugis nicht mehr finden. Habt Ihr vielleicht eine Liste, wo diese Zipfiles alle übersiichtlich zu finden sind?

          Danke mit schönen Grüßen, Wolfgang

           
          • Ellen (Support-Team) 3:11 pm on April 21, 2016 Permalink | Log in to Reply

            Hallo Wolfgang,
            oh ja, bitte entschuldige, wir werden auf jeden Fall auch im neuen Design wieder alle Beispiel-Child-Themes zur Verfügung stellen. Vorab kannst du das Bugis Child Theme über diesen Link herunterladen: Bugis Child Theme.
            Grüße, Ellen

            • hiddenline 5:55 pm on April 21, 2016 Permalink | Log in to Reply

              Habe es mir schon selber gebastelt, wollte nur Bescheid geben, bestimmt suchts bald mal wieder jemand.
              Schön wäre es, wenn irgend wo alle Informationen zu den verschiedenen Themes an zentraler Stelle zu finden wären (z.B. in Listenform).
              PS: Ich arbeite schon echt seit langem mit Euren Themes und bin immer wieder begeistert.

        • marianamatija 2:10 am on April 16, 2016 Permalink | | Resolved
          • Ellen (Support-Team) marked this resolved
            8:55 am on April 16, 2016
          • Ellen (Support-Team) marked this unresolved
            8:55 am on April 16, 2016

          Tags: , , child theme, , , ,   

          I’m having trouble with the “Customize” option 

          Hello! I’m using a Child version of the Zuki theme for my blog (www.cualquiercositaescarino.com) and everything has been working right for a long time… but today I wanted to update the header image, and I noticed that the Customize option is not working correctly. The page loads, but it doesn’t give me any options (as if the theme is not installed, or something), and I can’t see the widgets or the options to change colors, or anything else.

          Do yo know if this has anything to do with the lates WordPress update? Or do you have information of anyone else having this same problem? It’s weird, because it worked perfectly before, and I haven’t moved anything additional (just new posts and comments).

          I’d really appreciate any help. Thanks!

           
          • Ellen (Support-Team) 8:55 am on April 16, 2016 Permalink | Log in to Reply

            Hi there,
            I’m so sorry for this, there is an update out already (please have a look at the Zuki update infos). You would need to use Zuki version 1.1.3.
            Best, Ellen

          • anitabora 6:49 am on September 12, 2016 Permalink | Log in to Reply

            Hi Mariana – I’m having exactly the same issue. Would you be able to let me know how this was resolved?

            @ellen – tagging you – please help!

          • anitabora 6:57 am on September 12, 2016 Permalink | Log in to Reply

            “How to Update Your Theme: You can download the new theme version with the same download link you received with your theme purchase. ”

            I tried going to the download link (I purchased it in 2011). But the link says its expired.

            • Marc (Support-Team) 8:07 am on September 13, 2016 Permalink | Log in to Reply

              Hi @anitabora,

              in this case you need to purchase another 12 months of updates here. Your new download link will work again for 12 months after your purchase.

              Best,
              Marc

        • manfredb 9:23 am on November 18, 2015 Permalink | | Flag unresolved

            Tags: child theme,   

            Child Themes in Themes integrieren 

            hallo, ich hatte das schon einmal angeregt – aber wahrscheinlich an falscher Stelle …
            Wäre es nicht eine gute Idee (und praktisch für uns Käufer) die Child Themes gleich in die Themes zu integrieren?
            Macht bei einzelnen Themes vielleicht nicht so viel Sinn – aber als ThemeBundle-Käufer würde ich mich darüber freuen und ich könnte mein Nachladescript in Rente schicken ;-)

            viele Grüße
            Manfred

             
            • Marc (Support-Team) 1:38 pm on November 19, 2015 Permalink | Log in to Reply

              Hallo Manfred,

              vielen Dank für deine Anregung. Gerne leite ich diese als Feature Request weiter.

              Viele Grüße
              Marc

          • edi_goetschel 5:20 pm on October 14, 2015 Permalink | | Flag unresolved

              Tags: , child theme, Codex   

              Fehlermeldung Child Theme Baylys 

              Bei der Einrichtung eines Child Themes für dasTheme Baylys mit einer function.php (vgl. http://codex.wordpress.org/Child_Themes) bekomme ich die Fehlermeldung, dass das übergeordnete Theme fehle.

              Das Child Theme funktioniert, aber die Fehlermeldung ist irritierend.

               
              • Marc (Support-Team) 9:55 am on October 16, 2015 Permalink | Log in to Reply

                Hallo,

                das ist durchaus verwirrend. Bitte prüfe erneut die folgende Zeile, die sich zwingend im auskommentierten Bereich der style.css im Child-Theme-Ordner befinden muss:

                 Template:     baylys

                Du kannst allerdings auch das bereits vorbereitete Baylys-Child-Theme verwenden, welches in der Dokumentation verlinkt ist.

                Viele Grüße
                Marc

              • edi_goetschel 4:39 pm on December 7, 2015 Permalink | Log in to Reply

                Danke, ich werde das versuchen.

            • cht21 11:08 pm on September 27, 2015 Permalink | | Unresolved
              • Ellen (Support-Team) marked this unresolved
                12:39 pm on September 30, 2015

              Tags: broken, child theme, , ,   

              Ubud Child Theme 

              Hallo zusammen,
              da ich mir gerade einen Wolf gesucht habe, dachte ich, ich poste das hier mal ins Forum, für andere die dieses Problem haben:

              Wenn man nach Einrichtung des Ubud-Themes das Child-Theme aktiviert, verschwinden die bereits erstellten Posts/Thumbnails auf der Startseite. Die Lösung: man muss unter Design > Anpassen > Theme Optionen gehen und die beiden Einstellungen unter “Standard Bilder-Grid” und “Vorschaubild-Format” einmal auf einen anderen Wert setzen, speichern, und danach wieder auf die gewünschten Werte zurücksetzen und speichern. Dann geht’s :)

              Gefunden habe ich die Lösung versteckt in diesem Thread: http://themeforum.elmastudio.de/2014/12/27/making-a-ubud-child-theme/

              VG Christiane

               
              • Ellen (Support-Team) 12:38 pm on September 30, 2015 Permalink | Log in to Reply

                Hallo Christiane,
                vielen herzlichen Dank für deinen Hinweis, das sollte natürlich nicht so sein. Ich schaue mal, ob ich das im nächsten Update so hinbekomme, dass alle Einstellungen übernommen werden.
                Es tut mir sehr leid, dass du solche Probleme mit dem Child-Theme hattest. Ich hoffe es hat dich nicht zu viel Zeit gekostet.
                Ganz viele Grüße, Ellen

            • matthiashh2015 8:32 am on September 25, 2015 Permalink | | Resolved
              • matthiashh2015 marked this resolved
                11:31 am on September 25, 2015
              • matthiashh2015 marked this unresolved
                10:02 am on September 25, 2015

              Tags: , child theme   

              Black Walnut: Child-Theme-Vorlage 

              Hallo Ellen,
              ich habe mir gerade die Child-Theme-Vorlage für das Black Walnut Theme installiert.
              Nach der Aktivierung werden Inhalt und Menüleiste nicht mehr angezeigt. Dabei habe ich aber noch
              gar keine Einträge in der style.css vom Child-Theme gemacht. Ich hätte erwartet, dass die Seite dann
              noch so aussieht wie vorher.
              Ich hab noch mal weiter getestet: Bei einer Startseite mit 4 Fotos sind diese nach der Aktivierung des Child-Themes
              nicht mehr zugeordnet. Wenn ich das Theme selbst wieder aktiviere sind sie da. Heißt es ich muss alle Einstellungen
              (Startseiten-Fotos, Menüstruktur) für das Child-Theme noch mal neu machen?
              Viele Grüße
              Matthias

               
              • matthiashh2015 11:31 am on September 25, 2015 Permalink | Log in to Reply

                Lösung gefunden: Die Theme-Einstellungen (Zuordnung der Startseiten-Fotos, Menüleiste usw.) musste beim Child-Theme auch noch mal gemacht werden. D.h. es wäre einfacher gewesen, das Black Walnut Theme und das Child-Theme zu installieren und dann gleich mit dem Child-Theme zu arbeiten.

            • Hartmut 9:52 am on September 16, 2015 Permalink | | Resolved
              • Ellen (Support-Team) marked this resolved
                12:03 pm on September 16, 2015
              • Ellen (Support-Team) marked this unresolved
                12:03 pm on September 16, 2015

              Tags: child theme,   

              wetachildthemefolder.zip produziert nur Fehlermeldung

               
              • Ellen (Support-Team) 12:03 pm on September 16, 2015 Permalink | Log in to Reply

                Oh bitte entschuldige diesen Fehler, der Link funktioniert jetzt wieder.
                Viele Grüße, Ellen

            • Bernd 11:13 am on September 7, 2015 Permalink | | Flag unresolved

                Tags: child theme, css edit   

                Waipoa child theme 

                Kann die style.css des Child Theme direkt geändert/erweitert werden? Ich würde gern ‘Simple Custom CSS’ dazu verwenden, im Moment wird damit aber die style.css des Parent Themes geändert.

                Hat jemand eine gute Idee dazu??

                 
                • Marc (Support-Team) 11:15 am on September 9, 2015 Permalink | Log in to Reply

                  Hallo,

                  die Plugins (wie auch Simple Custom CSS) sollten den dort eingetragenen CSS-Code bloß zusätzlich ausführen. Damit kannst du bestehende CSS-Regeln überschreiben. Änderungen an der Datei style.css dürften diese Plugins nicht vornehmen.

                  Wenn du ein Child-Theme verwendest, kannst du die Änderungen direkt in die style.css des Child-Themes schreiben. In beiden Fällen lässt du das Parent-Theme unangetastet, so dass deine Änderungen im Falle eines Updates nicht überschrieben werden.

                  Viele Grüße
                  Marc

              • yuka 5:55 am on August 16, 2015 Permalink | | Flag unresolved

                  Tags: child theme   

                  Thank you for your amazing work. I really like your design and photos.
                  I’m Japanese and it’s lovely that I can find some Japanese word on your site.

                  One question.
                  I would like to make ubud child theme, but I can’t make it following way.
                  Please tell me how I can do it.

                  Thanks

                  ——————————————————————————————————————–
                  style.css

                  /*
                  Theme Name: ubud_child
                  Template: ubud
                  */

                  function.php

                  <?php //

                  add_action( 'wp_enqueue_scripts', 'theme_enqueue_styles' );
                  function theme_enqueue_styles() {
                  wp_enqueue_style( 'parent-style', get_template_directory_uri() . '/style.css' );

                  }

                   
                • berlindave 2:33 pm on May 24, 2015 Permalink | | Flag unresolved

                    Tags: child theme,   

                    Hallo,
                    ich habe auf meinem Blog eine bessere Child-Theme-Lösung für Waipoua veröffentlicht: http://www.ja-gut-aber.de/waipoua-child-theme/

                    Möge sie auch für andere nützlich sein!

                    Herzliche Grüße
                    Dave

                     
                  • kOoLiNuS 11:36 am on May 14, 2015 Permalink | | Flag unresolved

                      Tags: black, child theme, dark,   

                      a dark variant child theme for Nilmini 

                      Hello there,

                      anyone knows or has realized a black / dark version of Nilmini? TIA

                       
                      • Ellen (Support-Team) 10:35 am on May 19, 2015 Permalink | Log in to Reply

                        Hi there,
                        unfortunately I’m not aware of a black child theme version of Nilmini out theme, maybe anyone else knows?
                        Best, Ellen

                    • Kata 6:46 pm on May 6, 2015 Permalink | | Unresolved
                      • Kata marked this unresolved
                        9:11 pm on May 13, 2015
                      • Kata marked this normal
                        9:11 pm on May 13, 2015
                      • Ellen (Support-Team) marked this resolved
                        10:56 am on May 9, 2015
                      • Ellen (Support-Team) marked this unresolved
                        10:56 am on May 9, 2015

                      Tags: child theme, , , , ,   

                      Hi,

                      I am having troubles with overriding functions.php. It is basicly the same problem as http://themeforum.elmastudio.de/2015/03/06/cant-reach-incwidgets-php-from-child-theme/ and http://themeforum.elmastudio.de/2015/01/07/unable-to-change-widgets-php-file-in-child-theme/
                      I have tried to read through the comments on the two forum posts I mentioned above but I still can’t figure this out.

                      I wanted to do some changes to widgets.php (put ‘offset’ => 3 so the big and medium recent posts won’t show the same posts).

                      I made a folder in the child theme called “inc”, inside of that folder I copied the widgets.php file from the parent theme and added ‘offset’ => 3 on the right place.
                      After this the site takes no changes, so the widgets still show the same posts.
                      Then I added this line: “require( get_template_directory() . ‘/inc/widgets.php’ );” to the functions.php in my child theme folder. After that my site went blank.

                      Is this not the right procedure? Am I forgetting something? I have been trying to get this to work for a while so I would really appreciate some help.

                      Thank you.

                       
                      • Ellen (Support-Team) 10:56 am on May 9, 2015 Permalink | Log in to Reply

                        Hi Kata,

                        could you please try to add your new widgets.php file to your child theme in an “inc” folder and then include your new file in your child theme’s functions.php like so:

                        include get_stylesheet_directory() . '/inc/widgets.php';
                        

                        Please let me know, if this is still not solving the issue.
                        Best, Ellen

                        • Kata 11:19 pm on May 12, 2015 Permalink | Log in to Reply

                          Hi Ellen,

                          When I added “include get_stylesheet_directory() . ‘/inc/widgets.php’; ” , the page went blank,
                          but when I changed it to “include get_stylesheet_directory() . ‘/Zuki-Child/inc/widgets.php’ ”
                          (I added the child folder name before /inc) , the page does NOT go blank but I can’t see any the changes that I made. So It seems like I am not able to override.

                          I had already put my new widgets.php in an inc folder in my child theme, please see the following link for a screenshot: http://oi59.tinypic.com/ac4zdy.jpg
                          You can also take a look at this link http://oi59.tinypic.com/nlod3b.jpg to see my functions.php, I have commented out the commands that make the page blank

                          I hope you understand my problem.

                          Thans again!

                          • Marc (Support-Team) 12:42 pm on July 3, 2015 Permalink | Log in to Reply

                            Hi,

                            the code provided by @ellen is correct in general but the classes within the widgets.php cannot be included twice. Unfortunately there is no elegant way for update safe changes of the widget code.

                            You can simply remove the following line from your parent themes functions.php:

                            require( get_template_directory() . '/inc/widgets.php' );

                            A theme update would reverse your changes, so you need to be aware to remove this line in case of an update again.

                            A really messy but updates safe way would be to rename the classes in your custom widgets.php and unregister the original widgets before registering the new ones. Unfortunately the class name is used as CSS class as well, so you need to duplicate the widgets CSS code to fit to your new widgets. I hope this is even understandable :(

                            Best,
                            Marc

                    • zeggy 4:53 am on March 6, 2015 Permalink | | Resolved
                      • Ellen (Support-Team) marked this resolved
                        9:58 am on March 9, 2015
                      • Ellen (Support-Team) marked this unresolved
                        9:58 am on March 9, 2015
                      • Ellen (Support-Team) marked this normal
                        9:58 am on March 9, 2015
                      • Ellen (Support-Team) marked this resolved
                        9:58 am on March 9, 2015
                      • Ellen (Support-Team) marked this unresolved
                        9:58 am on March 9, 2015

                      Tags: child theme, ,   

                      Can’t reach inc/widgets.php from child theme 

                      Hey guys,

                      As the title, I can’t override the functions.php to require child theme’s inc/widgets.php.

                      zuki/functions.php has this at the end(line 549):

                      require( get_template_directory() . ‘/inc/widgets.php’ );

                      As you know, the zuki_child/functions.php compliments the main file, rather than overriding it. So if I try to call

                      require( get_stylesheet_directory() . ‘/inc/widgets.php’ ); per this , site goes to blank. It’s expected cause we’re trying to require two.

                      If I comment out the line from the original functions.php, everything works perfect, but as you know, modifying the original files contradicts with the use of a child theme.

                      Any workarounds or suggestions?

                       
                      • Ellen (Support-Team) 9:58 am on March 9, 2015 Permalink | Log in to Reply

                        Hi there,
                        in this case it should work, if you also include the inc folder and the widgets.php file into your child theme folder or? I hope I understood everything correctly and my reply is helpful.
                        Best, Ellen

                      • SvenE 9:12 am on June 1, 2015 Permalink | Log in to Reply

                        Hi Ellen,

                        same story here. I use Dorayaki but can’t get an overridden widgets.php to work. I tried to overwrote functions.php, but that resulted in an error.

                        Can you help out?

                        Sven

                    c
                    compose new post
                    j
                    next post/next comment
                    k
                    previous post/previous comment
                    r
                    reply
                    e
                    edit
                    o
                    show/hide comments
                    t
                    go to top
                    l
                    go to login
                    h
                    show/hide help
                    shift + esc
                    cancel