Updates from newapiratin Show/Hide Comments | Keyboard Shortcuts

  • newapiratin 8:16 pm on March 10, 2017 Permalink | Flag unresolved

      Tags:   

      »Kategorie: « entfernen 

      Hallo,
      ich möchte den Ausdruck »Kategorie: « gern auf den Projektseiten entfernen.
      Ich habe bereits ein ein Child-Theme. Könnte mir jemand einen Tipp geben, wie ich das mache?

      Tausend Dank!

       
      • newapiratin 8:21 pm on March 10, 2017 Permalink | Log in to Reply

        Am liebsten würde ich auch auf der Startseite unter den jeweiligen Projektüberschriften den Link auch ganz rausnehmen.
        Meine Seite: http://www.mannausobst.eu

        Vielen Dank für Eure Hilfe.

      • DushanWegner 12:42 pm on March 11, 2017 Permalink | Log in to Reply

        Hi newapiratin,

        ich bin »Anwender« (also: nicht Elmastudio-Vertreter). Hier meine Lösungs-Idee – ohne Gewähr!

        Das »Kategorie: « (auch: »Schlagwort: « etc.) wird von der WordPress-Funktion »get_the_archive_title« realisiert. Das ist die Funktion, die zB das Uku-Theme in »archive.php« aufruft.

        Um das zu entfernen, willst du folglich die Funktion »get_the_archive_title« überschreiben. Das macht man am besten in funtions.php (in deinem Child-Theme, klar).

        Auf http://wordpress.stackexchange.com/questions/179585/remove-category-tag-author-from-the-archive-title habe ich eine Lösung gefunden.

        Um die Funktion zu überschreiben fügst du Folgendes in deine functions.php (nochmal: im Child-Theme!) ein:

        add_filter( ‘get_the_archive_title’, function ($title) {
        if ( is_category() ) {
        $title = single_cat_title( ”, false );
        } elseif ( is_tag() ) {
        $title = single_tag_title( ”, false );
        } elseif ( is_author() ) {
        $title = ” . get_the_author() . ” ;
        }
        return $title;
        });

        Ich habe es getestet (Code von obigem Link kopiert), und bei mir funktioniert es, kann aber keine Garantie übernehmen, logisch! Ich würde immer alles erst auf Staging/Test-Site probieren.

        – Vielleicht hat das Team Elmastudio eine elegantere Lösung, klar… :)

        Lieben Gruß
        Dushan

        • newapiratin 11:51 am on March 13, 2017 Permalink | Log in to Reply

          Hi Dushan,
          Vielen Dank für deine Hilfe!
          Der Thread, den du verlinkt hast, trifft mein Thema genau.

          Leider funktioniert es bei mir nicht.
          Ich habe den Code entsprechend in die functions.php im child theme eingefügt, aber »Kategorie: « erscheint immer noch.

          Hast du es auch bei Zeitreise getestet? und in deutsch?
          Noch eine Idee?

          DANKE!

          • Marc (Support-Team) 12:29 pm on March 14, 2017 Permalink | Log in to Reply

            Hallo,

            bitte kopiere den Code direkt aus dem von Dushan angegeben Beitrag, da der in den Beitrag hier eingefügte Code fehlerhaft dargestellt wird.

            Bitte verwendet zum Posten von Code im Forum den folgenden Shortcode: [code]Dein Code hier…[/code]

            Viele Grüße
            Marc

            • DushanWegner 8:46 am on March 15, 2017 Permalink | Log in to Reply

              Danke, die Frage hatte ich, offensichtlich ;-) … nächstes Mal genau so!

            • newapiratin 2:26 pm on March 15, 2017 Permalink | Log in to Reply

              Hi Marc,
              vielen Dank.
              Ich habe den Code exakt kopiert (von dem anderen Beitrag)

              Aber der Ausdruck »Kategorie: « auf der Projektseite ist immer noch da. Eigentlich ist dafür die gesamte Unterzeile auf der Homepage weg-
              Was ich wollte:

              kleine Unterzeile auf der Homepage (am liebsten ohne Link).
              und ebenso auf der Projektseite selbst. »Kategorie: « sollte nicht davor stehen.

              Vielen Dank

              • Marc (Support-Team) 3:16 pm on March 17, 2017 Permalink

                Hallo,

                ich bin mir leider nicht sicher, was genau du meinst. Könntest du dies anhand eines Screenshots näher erläutern?

                Der folgende Code sollte das “Kategorie: ” entfernen. Dies hat in meinem kurzen Test funktioniert:

                add_filter( 'get_the_archive_title', function ( $title ) {
                
                    if( is_category() ) {
                
                        $title = single_cat_title( '', false );
                
                    }
                
                    return $title;
                
                });
                

                Bitte habe Verständnis dafür, dass wir für individuelle Anpassungen keinen Support im Forum leisten können.

                Viele Grüße
                Marc

            • newapiratin 11:56 am on March 23, 2017 Permalink | Log in to Reply

              Vielleicht liegt es am child theme.
              Habe nochmals deinen Code (siehe oben in die functions.php im child theme eingefügt, aber leider keine Änderung.
              zu sehen hier:
              http://mannausobst.eu/portfolio/schuld-und-buehne/

              Kategorie: steh immer noch da. (auch nach cache reload)

              danke für die Hilfe!

    • newapiratin 9:32 am on November 29, 2016 Permalink | Flag unresolved
         

        Add Link to Title in Zeitreise 

        Ich möchte gern zu dem Schriftzug, der unter Titel der Website gross auf dem Slider steht, einen Link hinzu fügen.
        Gruss, Anke

         
        • Marc (Support-Team) 2:09 pm on November 30, 2016 Permalink | Log in to Reply

          Hallo Anke,

          ein Klick auf den Titel in Zeitreise führt zu einem Herunterscrollen zu der Stelle, ab der der folgende Seiteninhalt beginnt. Um diesen Link anzupassen, müsstest du Änderungen an den Theme-Dateien vornehmen. Zu diesem Zweck empfehle ich dir die Verwendung eines Child-Themes. Ein vorbereiteter Child-Theme-Ordner ist in der Zeitreise-Dokumentation verlinkt.

          Dieser Link wird in der header.php des Themes gesetzt.

          Bitte habe Verständnis dafür, dass wir für individuelle Anpassungen keinen Support im Forum leisten können.

          Viele Grüße
          Marc

      • newapiratin 2:30 pm on October 16, 2016 Permalink | Flag unresolved

          Tags: , , ,   

          Hallo Ihr,
          vielen Dank für Eure wundervollen themes, habe jetzt schon zwei (Moka und Zeitreise) verwendet und viel Freude.
          Im Theme Zeitreise möchte ich gern alle Schriften, die im Moment 21 px gerendert werden
          (Artikeltexte, Footer, Kategorien etc) ein wenig verkleinern.

          ich habe bereits ein child theme in Benutzung, bin mir aber unsicher, welcher css Code die gewünschte Änderung hervorruft, ohne weitere Abhängikeiten zu zerstören.

          Danke, falls ihr kurz helfen könnt!
          Herzlich, anke

           
          • newapiratin 10:32 pm on October 16, 2016 Permalink | Log in to Reply

            Die obige Frage habe ich selbst lösen können .. aber jetzt habe ich ein Problem, an dem ich schon geraume Zeit verzweifle ; ( vielleicht weiss jemand Rat?
            Und zwar ist mein Seiten-Titel .. plötzlich auf den Unterseiten weiss (auf weiss) weshalb man ihn nicht sieht. Ebenso ist der schliessen Button beim Menu schwarz (auf schwarz) weshalb man ihn ebensowenig sieht… ich kann den Fehler in den Zuweisungen einfach nicht finden..

            hier ist die Seite: http://www.mannausobst.eu

            • Marc (Support-Team) 11:32 am on October 17, 2016 Permalink | Log in to Reply

              Hallo Anke,

              prüfe bitte einmal die Einstellung im Dashboard unter Design -> Anpassen -> Theme Optionen -> Start-Seite. Hast du dort einen Haken bei “Helle Header Text-Farbe (Wähle eine helle Text-Farbe, wenn du dunkle Slider-Bilder nutzt.)” gesetzt? Bitte ändere die dortige Einstellung einmal und speichere sie ab, danach kannst du sie wieder auf die von dir gewünschte Einstellung setzen.

              Viele Grüße
              Marc

              • newapiratin 4:26 pm on October 17, 2016 Permalink | Log in to Reply

                Hallo Marc,
                Danke für deine Antwort …Das hatte ich natürlich schon (und habe ich auch jetzt auf deinen Rat hin noch mal) versucht. Leider ohne Erfolg.
                Das Menü item stellt sich brav auf weiss und wieder zurück. Schliessen bleibt schwarz, egal, was eingestellt ist.

                ich könnte dir mal einen Screenshot senden (wie?) mit den berechnetetn STilen. Habe das nämlich mal mit eurem Demo verglichen .. kann es aber nicht entschlüsseln, weil es eine generierte index datei ist, die zuletzt zugreift.

                Ausserdem habe ich den leisen Verdacht, dass das rumspielen mit Google easys fonts evtl. an dem Fehler schuld ist.
                Jedenfalls funtioniert es auch nicht, wenn ich das child theme ausschalte und nur die originale style.css verwende.

                Beim Logo links oben habe ich mit !important ein workaround gefunden (wahrscheinlich auch nicht ganz korrekt)

                DANKE!!!

                PS. Google Easy Fonts habe ich inzwischen deaktiviert

              • newapiratin 4:40 pm on October 17, 2016 Permalink | Log in to Reply

                Sollte ich eigentlich in der style.css des child themes nur meine Änderungen/ Ergänzungen abspeichern oder zusätzlich die gesamten Styles des parent themes übernehmen (das habe ich bisher nicht)?

              • newapiratin 5:32 pm on October 17, 2016 Permalink | Log in to Reply

                Mitbetroffen ist auch das kleine Häkchen was den Untermenüpunkten voraus geht .. und inzwischen – einfach durch das hin und her schalten, bei mir auch das menü… HILFEE!! leider ist so nix navigierbar ..

                und es scheint auf jeden Fall in irgendeinem Zusammenhang zu der Auswahl, die du oben meinst Design -> Anpassen -> Theme Optionen -> Start-Seite stehen, denn trotz ausgewähltem dunklen header (und entsprechend korrekter Vorschau)

                erhalte ich folgendes auf der Seite
                Menü

                sorry, falls ich was übersehen, aber ich weiss nicht weiter.

              • newapiratin 12:06 pm on November 4, 2016 Permalink | Log in to Reply

                @834rd keine Meldung mehr vom Team. kannst du evtl. helfen? (habe oben deine wertvollen Tip gelesen. Danke. anke

          • newapiratin 10:33 am on October 20, 2016 Permalink | Log in to Reply

            Hallo @Marc, Ich brauche immer noch dringend Hilfe mit dem bug. Die Seite ist nicht navigierbar! Bitte…

            • Marc (Support-Team) 3:06 pm on November 7, 2016 Permalink | Log in to Reply

              Hallo Anke,

              leider komme ich einfach nicht dahinter, woher das Problem rühren könnte.

              In der style.css des Child-Themes solltest du nur deine Anpassungen eintragen, die style.css des Parent-Themes wird automatisch geladen.

              Folgender Code sollte den kleinen Pfeil und den Schließen-Button in deinem Overlay weiß färben:

              #overlay-wrap button {
              	color: #fff;
              }
              

              Welche Probleme bestehen derzeit noch?

              Viele Grüße
              Marc

              • newapiratin 2:33 pm on November 22, 2016 Permalink | Log in to Reply

                Hallo Marc,
                zunächst danke!
                Wir haben nun inzwischen auf ein helles Header – Bild umgestellt – aber der »Fehler« hell/ dunkel Schrift im Headerbereich bleibt. Nun habe ich den Haken weggemacht (bei helle Schrift für dunkle slides) dennoch ist der Titel weiterhin weiss.
                Ich würde gern den zugrundeliegenden Fehler beheben, ohne immer neue Teillösungen zu finden. Meinst du, ein komplettes neu installieren des Zeitreise-Themes könnte Abhilfe schaffen?

                Noch was zum Forum:
                leider bekomme ich (trotz: Notify me of followup comments via e-mail. ) keine Nachricht über Antworten in dem Thread. Stattdessen über neue Forumbeiträge in allen Foren … was unpraktisch ist.

                Deshalb habe ich, nachdem ich anfangs täglich nach Antworten geschaut habe, jetzt erst deine Nachricht vom Nov 7 gefunden.

                Gruss, Anke

              • newapiratin 3:25 pm on November 22, 2016 Permalink | Log in to Reply

                Mein Backend sieht übrigens so aus:
                https://snag.gy/xCDb2i.jpg

              • newapiratin 3:48 pm on November 22, 2016 Permalink | Log in to Reply

                Ok, manche Änderungen treten seltsamer Weise erst nach ca. 1h in Kraft. Also hat sich das Problem zum Teil behoben ..
                Ein Frage habe ich: Ich würde auf den Folgeseiten gern beim Seitentitel das Bild mit Ensemble ausblenden (so dass nur noch »Mann aus Obst« steht) – wie wäre das am einfachsten?

                • Marc (Support-Team) 4:30 pm on November 22, 2016 Permalink | Log in to Reply

                  Hallo Anke,

                  verwendest du evtl. ein Caching-Plugin? Bitte achte in diesem Fall darauf nach Änderungen den Cache zu leeren, sonst werden dir zwischengespeicherte Seiten / Elemente, die vor der Änderung generiert wurden, ausgeliefert.

                  Ich vermute du meinst das Resultat der Verwendung folgenden Codes:

                  .not-front a.site-logo {
                  	display: none;
                  }
                  

                  Viele Grüße
                  Marc

                  • newapiratin 9:17 am on November 29, 2016 Permalink

                    Danke, Marc.
                    Cache leeren mache ich eigentlich immer. Aber manchmal hängt es trotzdem. Hab jetzt den Super Cache mal deaktiviert.
                    Danke für das css snippet. Läuft!
                    Habe immer noch ein Problem im Menu:
                    meine Transparenz ist plötzlich weg und das Bild drunter wird auch ausgeblendet, was nicht soll (nur die Typo soll weg)

                    Was soll:
                    Menü – weisser Overlay teiltransparent und alles schwarze Schrift, Bild sichtbar – Schriftzug weg

                    Aber Schritt für Schritt kommen wir der Sache näher und verzagen nicht : )

                    das ist der code, der bereits im css ist:

                    /*— Menü Transparenz —*/
                    .overlay-show .slick-slider {
                    opacity: 1;
                    }

                    .overlay-show.home.headerslider h1.site-title, .overlay-show.template-front.headerslider h1.site-title,
                    .overlay-show.home.headerslider p.site-description, .overlay-show.template-front.headerslider p.site-description {
                    opacity: 0;
                    }

                    #overlay-wrap {
                    color: #000;
                    background-color: rgb(255, 255, 255);
                    background-color: rgba(255, 255, 255, 0.85);
                    }

                  • Marc (Support-Team) 11:28 am on December 8, 2016 Permalink

                    Hallo Anke,

                    hast du diesen Code gesetzt?

                    #overlay-wrap, .pace .pace-progress, .testimonials-wrap {background: #fcfcfc;}
                    

                    Dieser überschreibt die Transparenz. Wenn du in deinem Code ein “!important” hinter den Wert und vor das Semikolon setzt, reicht dies evtl. schon um die Transparenz zu erzwingen.

                    Der Titel lässt sich mit folgendem CSS-Code bei geöffnetem Overlay ausblenden. Der Code lässt sich entsprechend auch für andere Elemente bzw. Eigenschaften anpassen:

                    	.overlay-show #masthead {
                    		display: none;
                    	}
                    

                    Viele Grüße
                    Marc

          • newapiratin 3:53 pm on November 24, 2016 Permalink | Log in to Reply

            Danke, Marc.
            Cache leeren mache ich eigentlich immer. Aber manchmal hängt es trotzdem. Hab jetzt den Super Cache mal deaktiviert.
            Danke für das css snippet. Läuft!
            Habe immer noch ein Problem im Menu:
            meine Transparenz ist plötzlich weg und das Bild drunter wird auch ausgeblendet, was nicht soll (nur die Typo soll weg)

            Was soll:
            Menü – weisser Overlay teiltransparent und alles schwarze Schrift, Bild sichtbar – Schriftzug weg

            Aber Schritt für Schritt kommen wir der Sache näher und verzagen nicht : )

            das ist der code, der bereits im css ist:

            /*— Menü Transparenz —*/
            .overlay-show .slick-slider {
            opacity: 1;
            }

            .overlay-show.home.headerslider h1.site-title, .overlay-show.template-front.headerslider h1.site-title,
            .overlay-show.home.headerslider p.site-description, .overlay-show.template-front.headerslider p.site-description {
            opacity: 0;
            }

            #overlay-wrap {
            color: #000;
            background-color: rgb(255, 255, 255);
            background-color: rgba(255, 255, 255, 0.85);
            }

        c
        compose new post
        j
        next post/next comment
        k
        previous post/previous comment
        r
        reply
        e
        edit
        o
        show/hide comments
        t
        go to top
        l
        go to login
        h
        show/hide help
        shift + esc
        cancel