Updates from BorisN Show/Hide Comments | Keyboard Shortcuts

  • BorisN 8:04 pm on April 8, 2017 Permalink | | Resolved
    • BorisN marked this resolved
      7:26 pm on April 12, 2017
    • BorisN marked this unresolved
      8:04 pm on April 8, 2017

    Tags: ,   

    Uku – Full-Width Template – doesn’t get full-width?! 

    Hi,

    here is the example: https://www.nsonic.de/blog/full-width-test/

    This is a page where i set the template to full-width.
    As you can see: The Text is starting left on the page (still a border to the left browser-edge, is OK) but then it didn’t flow to the very right. It seems, that it is still at about 900px … only difference to Default-Template or Without Sidebar is where the text starts on the page

    What i like to see is getting the “full width” (maybe with a little bit of a edge) – Why? I like to insert a shortcode of a plugin (posts-grid, gallery, etc.) and currently they all are getting only about 900px for their own presentation…

    any idea to get it into full-width? Thanks a lot

     
    • Marc (Support-Team) 12:04 pm on April 11, 2017 Permalink | Log in to Reply

      Hi,

      thank you for noticing this bug. Until it gets fixed in a future update, please use the following additional CSS code:

      @media screen and (min-width: 66.250em) {
      	.page-fullwidth #primary .entry-header, .page-fullwidth #primary .entry-content {
      		width: 100% !important;
      		max-width: none !important;
      	}
      }
      

      Best,
      Marc

  • BorisN 10:37 am on April 1, 2017 Permalink | | Unresolved
    • BorisN marked this unresolved
      10:37 am on April 1, 2017

    Tags:   

    Uku – Neue Beiträge auf Startseite oder eigene Seite dafür 

    Moin, ich habe mir jetzt mal Uku installiert und eingerichtet. Schick :)

    Aber eine Frage für die Nutzung in einem Blog der nicht täglich mehrere neue Beiträge bekommt ;)

    Das Problem:

    • Durch die Nutzung der verschiedenen Abschnitte (Featured, 2 Spalten, etc.) wandert der Bereich mit “Neue Beiträge” recht weit nach unten. Sind neue Beiträge in keiner passenden Kategorie für die oberen Abschnitte, sieht ein Besucher diese nicht mehr sofort

    Die Frage:

    • lässt sich ein Abschnitt, irgendwo weiter oben einrichten, der z.B. die aktuellen 3 Beiträge präsentiert?
    • ODER: Lässt sich eine eigene Seite gestalten, auf der dann NUR “Neue Beiträge” gelistet werden? (dann könnte ich ein Menüpunkt “Aktuelles” einrichten der dorthin zeigt) – Vielleicht gibt es ja einen Shortcode oder Widget oder ähnliches, den ich auf eine Seite (z.B. Fullwidth Stil) legen könnte um das zu erreichen?
     
    • Pixelbart 2:54 pm on April 1, 2017 Permalink | Log in to Reply

      Hi BorisN,

      normalerweise legt man für seine “News” bzw. “Blog” Seite eine spezielle Seite fest und geht dann in die Einstellungen -> Lesen und stellt dort die Seite ein.

      Schau mal ob dir das schon reicht.

      LG Kevin

    • BorisN 10:56 pm on April 1, 2017 Permalink | Log in to Reply

      Eventuell habe ich mich unklar ausgedrückt :)

      Uku sorgt dafür, dass die “Standard”-Startseite (die mit den neuen Themen) ziemlich gepimpt wird mit diversen Abschnitten in verschiedenen Layouts (sehr hübsch)

      Die Frage ist jetzt, ob ich:
      a) die neuen Beiträge (egal welche Kategorie und Stichwort) irgendwo weit oben gezeigt werden können (nicht alle, nur die letzten 3-4 Stück oder so)
      b) oder ob ich irgendwie eine Seite bauen kann, auf der NUR der Uku-Abschnitt mit den neuen Beiträgen gezeigt wird? (Uku macht das sehr hübsch, zieht sich einen Beitrag heraus mit Bild auf voller Breite etc. – das möchte ich auf der reinen “neues”-Seite schon auch gerne haben

      • Marc (Support-Team) 3:50 pm on April 3, 2017 Permalink | Log in to Reply

        Hallo,

        leider ist es nur durch Anpassungen der index.php des Themes und ggf. weiteren CSS-Code-Anpassungen möglich die Sektionen zu verschieben. Gerne leite ich dies jedoch als Feature Request weiter. Für Anpassungen am Code empfehle ich dir dringend die Verwendung eines Child-Themes. Ein vorbereiteter Child-Theme-Ordner ist in der Uku-Dokumentation verlinkt.

        Wenn du allen Beiträgen ein Schlagwort oder eine Kategorie zuordnest, kannst du eine Schlagwort- bzw. Kategorie-Archiv-Seite dazu verwenden, alle Beiträge chronologisch aufzulisten.

        Viele Grüße
        Marc

        • BorisN 8:24 pm on April 5, 2017 Permalink | Log in to Reply

          Hey Marc,

          Danke erst mal :)
          Aber ich meine nicht unbedingt das verschieben der Abschnitte – Der “top Artikel”-Abschnitt kann ja recht lang sein.

          Nein, ich meine eher einen zusätzlichen Abschnitt, den man sich ganz oben oder unter den oberen Featured-Block setzen könnte um eine Anzahl von aktuellen Beiträgen (über alle Kategorien hinweg) anzuzeigen … Einfach weil sonst bei einem Blog für einen Besucher kaum zu finden ist, welches die aktuellen Beiträge sind (wenn man die anderen Abschnitte über dem “top artikel” nutzt) :)

          Evtl. kannst Du das als Feature-wunsch weitergeben – also ein kleiner Abschnitt unter dem oberen Featured Block oder optional darüber mit kompaktem Design um z.B. 2 oder 3 Spalten mit aktuellen Beiträgen zu haben :)

    • BorisN 7:32 pm on April 9, 2017 Permalink | Log in to Reply

      falls noch andere nach einer Lösung suchen… Ich probiere gerade folgendes: Es gibt Plugins um eine Anzahl neuer Beiträge anzuzeigen, per Shortcode auf einer Seite.
      Das Plugin “Advanced Recent Posts” macht dieses recht hübsch und einigermaßen passend zum Look des Themes.

      Das Hauptproblem dabei ist, dass das Theme bei eigenen Seiten die Breite für den Inhalt immer auf (vermutlich) 900px begrenzt und die Vorlage für Full-Width ignoriert. Dafür habe ich ein neues Ticket geöffnet – gibt bestimmt eine Lösung dafür über CSS :)

  • BorisN 2:30 pm on January 31, 2017 Permalink | | Unresolved
    • BorisN marked this unresolved
      2:30 pm on January 31, 2017

    Tags: ,   

    Bugis: Bildgröße lässt sich nicht ändern – Maximale Breite bei 1-Spalten-Layout wird nicht genutzt 

    Hallo Ellen,

    da mein alter Beitrag nicht weiter bemerkt wird (vermutlich ein Problem mit der Notification für die Antworten?) muss ich es leider mit einem neuen Beitrag versuchen – sorry, bitte nicht als Spam verstehen. Vielen Dank :)

    Ich habe in den Einstellungen unter “Medien” die Möglichkeit, Bildgrößen für Vorschaubilder, Mittelgroß und Groß zu hinterlegen.
    Bei “Groß” hatte ich bereits 1024 x 1024 als Maximum hinterlegt.
    Trotzdem werden neue Bilder (ich lade die per Drag&Drop in die Beiträge) als “Groß” maximal mit 660px horizontal angeboten. Die nächste Größe ist dann bereits “vollständige Größe” (ich lade die Bilder mit 2100px horizontal hoch)
    Auch Regenerate Thumbnails ändert daran nichts.
    Was übersehe ich? Begrenzt das Bugis-Theme die Bilder auf 660 Pixel? Kann irgendwie auch nicht sein, weil das Theme im Einspaltigen Modus Bilder mindestens bis 758 Pixel zeigen könnte.
    Was kann ich tun um die Bilder im einspaltigen Layout auf diese 758px zu bekommen?

    wenn ich im Media-Uploader etwas hochlade, kann ich keine Größe einstellen. Da ist nur ein Platzhalter für eine Drag/Drop-Aktion und der Hinweis auf die maximale Dateigröße von 200 MB.
    Wenn ich Bilder in einen Beitrag einfüge, dann ebenfalls per Drag&Drop auf den Text-Bereich.
    Wähle ich beim Beitragschreiben den Media-Button und klicke im Dialog auf “Dateien hochladen”, kann ich dort ebenfalls keine Größen einstellen (“Drag and Drop – oder Datei wählen-Button).
    Meine Webseite mit dem Bugis-Theme läuft unter http://www.nsonic.de

     
    • Marc (Support-Team) 4:43 pm on January 31, 2017 Permalink | Log in to Reply

      Hallo @borisn,

      bitte verzeih die späte Antwort. Ich antworte dir dazu im ursprünglichen Beitrag.

      Viele Grüße
      Marc

  • BorisN 7:46 pm on December 17, 2016 Permalink | | Unresolved
    • BorisN marked this unresolved
      10:42 am on December 19, 2016

    Tags: ,   

    Bugis Theme: Bildgröße aus Medien-Einstellung wird ignoriert 

    Hallo Ellen,

    ich habe in den Einstellungen unter “Medien” die Möglichkeit, Bildgrößen für Vorschaubilder, Mittelgroß und Groß zu hinterlegen.
    Bei “Groß” hatte ich bereits 1024 x 1024 als Maximum hinterlegt.

    Trotzdem werden neue Bilder (ich lade die per Drag&Drop in die Beiträge) als “Groß” maximal mit 660px horizontal angeboten. Die nächste Größe ist dann bereits “vollständige Größe” (ich lade die Bilder mit 2100px horizontal hoch)

    Auch Regenerate Thumbnails ändert daran nichts.

    Was übersehe ich? Begrenzt das Bugis-Theme die Bilder auf 660 Pixel? Kann irgendwie auch nicht sein, weil das Theme im Einspaltigen Modus Bilder mindestens bis 758 Pixel zeigen könnte.

    Was kann ich tun um die Bilder im einspaltigen Layout auf diese 758px zu bekommen?

     
    • Ellen (Support-Team) 7:11 am on December 21, 2016 Permalink | Log in to Reply

      Hallo,

      das ist komisch, eigentlich sollten die Bilder auch größer rein geladen werden können. Könntest du eventuell noch einmal prüfen, ob du auch die größte Bildgröße beim Import über den Medien-Button ausgewählt hast, wenn du die Bilder in den Beitrag einfügst?

      Ansonsten sag mir doch noch einmal kurz deine URL, dann schaue ich mal in den Code rein.

      Ganz viele Grüße,
      Ellen

      • BorisN 1:06 pm on January 18, 2017 Permalink | Log in to Reply

        Ping?

      • BorisN 10:35 am on January 25, 2017 Permalink | Log in to Reply

        OK, ich versuche es jetzt noch mal mit einem kompletten Reply in der Hoffnung, dass der Beitrag irgendwo bei Euch auftaucht und Du oder jemand aus dem Team mir helfen kann :)

        Also: wenn ich im Media-Uploader etwas hochlade, kann ich keine Größe einstellen. Da ist nur ein Platzhalter für eine Drag/Drop-Aktion und der Hinweis auf die maximale Dateigröße von 200 MB.
        Wen ich Bilder in einen Beitrag einfüge, dann ebenfalls per Drag&Drop auf den Text-Bereich.
        Wähle ich beim Beitragschreiben den Media-Button und klicke im Dialog auf “Dateien hochladen”, kann ich dort ebenfalls keine Größen einstellen (“Drag and Drop – oder Datei wählen-Button).
        Meine Webseite mit dem Bugis-Theme läuft unter http://www.nsonic.de

      • BorisN 10:36 am on January 25, 2017 Permalink | Log in to Reply

        Huch? Mein Reply taucht auf einer anderen Ebene auf – daher noch ein Versuch (nicht als Spam zu verstehen, möchte nur sicher stellen, dass es auch jemand an der richtigen Stelle sieht/findet)

        Also: wenn ich im Media-Uploader etwas hochlade, kann ich keine Größe einstellen. Da ist nur ein Platzhalter für eine Drag/Drop-Aktion und der Hinweis auf die maximale Dateigröße von 200 MB.
        Wen ich Bilder in einen Beitrag einfüge, dann ebenfalls per Drag&Drop auf den Text-Bereich.
        Wähle ich beim Beitragschreiben den Media-Button und klicke im Dialog auf “Dateien hochladen”, kann ich dort ebenfalls keine Größen einstellen (“Drag and Drop – oder Datei wählen-Button).
        Meine Webseite mit dem Bugis-Theme läuft unter http://www.nsonic.de

    • BorisN 10:21 am on January 9, 2017 Permalink | Log in to Reply

      Sorry, war im Urlaub. Jetzt wieder Zeit :)

      Also: wenn ich im Media-Uploader etwas hochlade, kann ich keine Größe einstellen. Da ist nur ein Platzhalter für eine Drag/Drop-Aktion und der Hinweis auf die maximale Dateigröße von 200 MB.

      Wen ich Bilder in einen Beitrag einfüge, dann ebenfalls per Drag&Drop auf den Text-Bereich.
      Wähle ich beim Beitragschreiben den Media-Button und klicke im Dialog auf “Dateien hochladen”, kann ich dort ebenfalls keine Größen einstellen (“Drag and Drop – oder Datei wählen-Button).

      Meine Webseite mit dem Bugis-Theme läuft unter http://www.nsonic.de

    • BorisN 1:05 pm on January 18, 2017 Permalink | Log in to Reply

      ping … Hilfe?! :)

      • Marc (Support-Team) 4:47 pm on January 31, 2017 Permalink | Log in to Reply

        Hallo @borisn,

        hier gab es eine Änderung im WordPress-Verhalten. Die Bildgröße für “Groß” wird leider durch die intern verwendete Angabe der Inhaltsbreite begrenzt. Diese findest du in der functions.php des Themes. Ich werde versuchen hierfür eine Lösung zu finden, so dass diese in einem Theme-Update einfließen könnte, bitte erwarte dieses jedoch nicht in nächster Zeit.

        Du kannst den Wert durch Anpassung folgender Code-Stelle anpassen:

        if ( ! isset( $content_width ) )
        	$content_width = 660; /* pixels */
        

        Viele Grüße
        Marc

        • BorisN 9:18 am on February 1, 2017 Permalink | Log in to Reply

          Ah, OK das ist natürlich “blöd” :) – Dann wird ja auch der Text breiter, richtig? Mein Ziel ist es eigentlich, ein Bild über die volle Breite zu bekommen – nicht den Text an den Rand klatschen zu lassen :)

          Ich probiere das aber mal aus – Der Text ist ja jetzt auch schon Breiter als 660px und daher vermute ich, dass in dem Theme content_width für andere Dinge steht… naja, Versuch macht klug :)

          Danke schon mal für den Hinweis.

        • BorisN 3:03 pm on February 1, 2017 Permalink | Log in to Reply

          Alles klar – das funktioniert und es hat keine Auswirkungen auf den Text sondern nur auf die Bilder (und/oder vermutlich andere Inhalte).

          Ich habe das in meinem Child-Theme überschrieben und das klappt. Allerdings nicht für vorhandene Beiträge (und ich mag jetzt auch nicht jeden Beitrag öffnen, Bild anklicken, Bearbeiten und wieder OK um die Einträge zu aktualisieren) … Damit kann ich aber leben

          Ich probiere das bei neuen Beiträgen mal mit der “vollen” Breite aus und entscheide dann was mir besser gefällt. Wenn ich alles auf die Breite gezogen haben möchte, könnte ich ja in der Datenbank die entsprechenden html-Stücke für die “width=660” ändern mit einem Tool/SQL-Befehl… na mal gucken :)

  • BorisN 11:57 am on April 14, 2015 Permalink | | Flag unresolved

      Tags: ,   

      Es geht mir um das Bild, dass man in Workshop als “Artikelbild” festlegen kann.

      In den Einstellungen habe bei dem Vorschaubild die Pixelzahl deutlich raufgesetzt. Empfehlung ist 670, da ich aber keine Seitenleisten habe, sind es bei mir 960.

      Wenn ich nun ein Bild als Artikelbild festlege, dann wird es unter der Artikelüberschrift schön groß angezeigt. Klickt man auf “weiterlesen” geschieht genau dasselbe.
      Ich kann natürlich auch KEIN Artikelbild festlegen und stattdessen das Bild einfach ganz oben als erstes in den Artikel einfügen. Auch jetzt wird es schön groß unter der Überschrift gezeigt.

      Was ist dann der Vorteil oder der Unterschied vom/zum “Artikelbild”?

      • Das Suchergebnis zeigt es nicht an
      • Es wird in der Artikelansicht auch nicht größer angezeigt (ich meine mal ein Theme gesehen zu haben, bei dem das Artikelbild dann über dem Artikel-Titel über die volle Breite ohne Rand gezogen wurde)

      Sollte man “Artikelbild” also überhaupt nutzen? Wofür?

      … Ich suche jetzt keine Probleme wo keine sind :D ich möchte nur sicherstellen, dass ich nicht etwas geniales übersehe und verpasse und mich später ärgere… noch könnte ich meine Artikel anpassen – in einem Jahr habe ich da keine Lust mehr dazu ;)

       
      • Marc (Support-Team) 7:10 am on April 16, 2015 Permalink | Log in to Reply

        Hallo,

        das Artikelbild kann z.B. auch durch geeignete Plugins weiterverwendet werden, hier ein Beispiel: http://www.elmastudio.de/wordpress/wordpress-tipp-fehlende-artikel-bilder-facebook/

        Darüber hinaus ist es so, dass wie von dir beschrieben, Themes, wie z.B. Zuki ( http://themes.elmastudio.de/zuki/2014/07/11/spices-we-love/ ), das Artikelbild noch etwas prominenter darstellen als ein in den Inhalt eingebettetes Theme. Daher ist es vor allem für einen eventuellen Theme-Wechsel interessant, das Artikelbild gesetzt zu haben, denn auch der Slider in Zuki z.B. verwendet diese Bilder und würde ohne Artikelbild leider nicht funktionieren.

        Des Weiteren brauchst du dir nach der entsprechenden Anpassung in den Medieneinstellungen keine Gedanken mehr über die Größe des Bildes machen, WordPress legt eine Kopie deiner hochgeladenen Bilder in der richtigen Größe an um sie in deinen Beiträgen anzuzeigen (das spart u.a. Ladezeit). Natürlich kannst du diese Größe auch beim Einfügen in den Inhalt manuell wählen, aber dies ist immerhin ein Schritt mehr :)

        Viele Grüße
        Marc

    • BorisN 8:56 pm on January 4, 2015 Permalink | | Unresolved
      • BorisN marked this unresolved
        8:04 pm on January 5, 2015
       

      Dorayaki – Suche lässt sich nicht (immer) aufrufen 

      Hallo,

      ich setze das Dorayaki-Theme ein. Ich habe ein Child-Theme davon erzeugt, wobei das komplette stly.css-File übernommen (und etwas angepasst) habe sowie die Verzeichnisse font und images.

      Das Problem hatte ich allerdings schon ohne den Weg über das Child-Theme und zwar auch auf der Demo-Seite von Elmastudio.

      Der Blog läuft auch – Bis auf die Suche, die zickt etwas.

      • Wenn die Webseite schmal ist, so dass das Hauptmenü reduziert angezeigt wird (mobile), dann öffnet der Klick auf die Lupe das Suchen-Feld – OK
      • Ist die Webseite aber breit genug für die Hauptnavigation, erscheint die Lupe oben rechts (gut). Klicke ich dann darauf, dann wird die Seite refresht, etwas scheint zu laden aber nichts passiert.

      Das hatte ich mit der Demo-Seite bei elmastudio auch (Windows / Mac, Chrome). Als ich das Theme selbst nutze, klappte das ein paar mal gut und ich schob das Thema zur Seite. Jetzt gerade merke ich, dass es nicht mehr funktioniert (Mac, Chrome / Safari)

      Link zur Seite: http://foto.nsonic.de

      Da ich die Suche selbst häufig nutzen werden, bin ich für eine Lösung dankbar :)

      Gruß

      Boris

       
      • Marc (Support-Team) 12:17 pm on January 7, 2015 Permalink | Log in to Reply

        Hallo Boris,

        ich konnte das Problem reproduzieren, jedoch nur beim mehrfachen Ändern der Fensterbreite. Bei einem direkten Aufruf hat die Suche auch auf deiner Seite immer einwandfrei funktionier. Ich werde das näher untersuchen.

        Viele Grüße
        Marc

      • BorisN 6:32 pm on January 7, 2015 Permalink | Log in to Reply

        Vielen Dank Marc! Ich dachte ich schon, ich werde verrückt – weil es bei mir auch mal ging und dann wieder nicht – an das Ändern der Fenstergröße hatte ich gar nicht gedacht.

        Ich hoffe, Du kannst da eine Lösung finden – Ich bin am Ende mit meinem Latein :)

    c
    compose new post
    j
    next post/next comment
    k
    previous post/previous comment
    r
    reply
    e
    edit
    o
    show/hide comments
    t
    go to top
    l
    go to login
    h
    show/hide help
    shift + esc
    cancel